Ask Your Question
1

How to turn off automount in Fedora 27?

asked 2017-12-28 07:34:09 -0600

billwilliams gravatar image

Hi,

How can I turn off automount in Fedora 27 permanently?

Thank you,

Bill

edit retag flag offensive close merge delete

Comments

This question could be closed as duplicate of: https://ask.fedoraproject.org/en/ques...

florian gravatar imageflorian ( 2017-12-28 15:35:23 -0600 )edit

Hi Florian, thanks for the link. However I have the issue when running command line also (without gdm for example). So I guess there is a systemd issue also, not only gnome? Thanks, Bill

billwilliams gravatar imagebillwilliams ( 2018-01-04 23:36:40 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-12-28 15:34:57 -0600

florian gravatar image

Without dconf-editor, from a terminal run:

gsettings get org.gnome.desktop.media-handling automount to read the current value.

To change it to false, run gsettings set org.gnome.desktop.media-handling automount false

edit flag offensive delete link more

Comments

@florian, thank you, this seems to be all that was needed.

billwilliams gravatar imagebillwilliams ( 2018-01-17 14:46:18 -0600 )edit
2

answered 2017-12-28 13:47:09 -0600

steveebey73742 gravatar image

dconf-editor and goto org > gnome > desktop > media-handling and uncheck auto-mount. if you use a different desktop, put the name of the desktop in place of gnome.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-28 07:34:09 -0600

Seen: 944 times

Last updated: Dec 28 '17