Ask Your Question
1

Fedora 27 ACPI error

asked 2017-12-30 13:12:00 -0500

E335 gravatar image

updated 2017-12-30 13:12:51 -0500

After upgrade from F26 to F27 I'm not able anymore to boot. Neither with F27 nor with the latest two available versions from F26. I always end in the emergency mode, getting the following errors with "journalctl -b -p 3":

..kernel: ACPI Error: Field [TBF3] at bit offset/length 262144/32768 exceeds size of target Buffer (262144 bits) (20170728/dsopcode-23..

..kernel: ACPI Error: Method parse/execution failed _SB.PCI0.GF0.GETB, AEAMLBUFFER_LIMIT (20170728/psparse-550)

..kernel: ACPI Error: Method parse/execution failed _SB.PCI0.GF0.ATRM, AEAMLBUFFER_LIMIT (20170728/psparse-550)

..systemd[1]: Failed to start Switch Root.

How to fix this in emergency mode? Thanks for your help!! Marco

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2017-12-30 14:38:29 -0500

Marc lml gravatar image

Have you tried disabling ACPI in the BIOS setup? Alternatively, you could try to boot with the option acpi=off.

This link gives more information on ACPI: https://access.redhat.com/solutions/5...

And here is an extended blog post on ACPI troubleshooting: https://01.org/linux-acpi/documentati...

edit flag offensive delete link more

Comments

Thanks. Found this:

  • Edit /boot/grub/grub.conf

    • Edit the kernel line and add the option acpi=off. Example: kernel /vmlinuz-2.6.18-194.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=off
    • Restart your system.

But neither sudo / su root / nano or anything similar works in the emergency mode :/# How to edit the grub.conf from emergency mode? Thanks!

E335 gravatar imageE335 ( 2017-12-30 15:37:08 -0500 )edit

Hit e when grub menu shows up, add acpi=off to the kernel command line, ctrl-x for booting with the added parameter.

fcomida gravatar imagefcomida ( 2017-12-30 17:13:42 -0500 )edit

ACPI error is gone, but still not booting, new errors are: Invalid PCI ROM header signature: expecting 0xaa55, got 0x0000 ERROR UNable to locate a BIOS ROM Fatal error during GPU init Memory type 2 has not been initialized

und deshalb wieder emergency mode ....

Danke für jeden Tipp!

E335 gravatar imageE335 ( 2017-12-30 17:46:59 -0500 )edit
0

answered 2017-12-31 06:24:38 -0500

E335 gravatar image

Fortunately I backed up my data before so I decided now to try a fresh install of F27, may be faster ...

edit flag offensive delete link more
0

answered 2017-12-31 06:43:13 -0500

E335 gravatar image

Just found the or one of the reasons. disk was full after upgrade... . Anyway I continued now fresh install, saves me the work to sort out stuff I don't need.

edit flag offensive delete link more

Comments

Good to hear you found the cause of the issue.

Marc lml gravatar imageMarc lml ( 2018-01-02 15:46:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-30 13:12:00 -0500

Seen: 4,186 times

Last updated: Dec 31 '17