English
Ask Your Question
0

Logitech Webcam c210 audio sped up Chipmunk style in Fedora27

asked 2017-12-31 10:53:09 +0000

srgcdev gravatar image

updated 2018-01-11 17:49:45 +0000

Hello everybody,

Since I updated to Fedora 27 I have some problems with the audio I record with the mic. I use audacity to record audio and the result sound is speed up like a chipmunk so I can't hear it properly. The problem is that the time when I'm recording the audio passes very slowly, maybe 3 real seconds are like 1 second in the program. I can reproduce it in audacity and sound-recorder.

When I'm using skype I have the same problem, my contacts can't hear me well. If I do the skype test call I hear the voice very accelerated. I have the same issue with other programs like linphone, etc.

The mic is an usb integrated in a webcam I have been using for many years and it was working perfectly in Fedora 26 and previous fedora versions. The webcam is Logitech, Inc. Webcam C210.

I don't have this problem in other distributions like debian 9 stable or ubuntu 16.04, but I have the same problem in debian sid gnome and latest manjaro gnome (17.1.1). I have also tested Fedora 27 Plasma too and the problem is the same. Maybe is a bug with the kernel 4.14 or the newest pulse version?

The weird thing is that sometimes it is working well, it works maybe 1 out of 10 times.

Any ideas? Have anybody the same problem?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Probably a change in default sampling rate in pulseaudio. Can you login as a different user (you can create a new one for testing) or boot f27 live and see what happens? Arch has a nice wiki for troubleshooting pulseaudio: troubleshooting

fcomida ( 2018-01-07 18:37:16 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-01-11 17:52:39 +0000

srgcdev gravatar image

Thanks to @fcomida I have solved the problem changing the sample rate in pulseaudio as described in the arch wiki:

default-sample-rate = 16000

The problem is solved in audacity and sound-recorder but not in skype. Maybe skype have a particular configuration to define the sample rate?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-12-31 10:53:09 +0000

Seen: 151 times

Last updated: Jan 11