How to turn off power management fedora 27?

asked 2018-01-04 22:56:26 -0600

billwilliams gravatar image

Hi,

How can I turn off power management completely in Fedora on my laptop?

In the gnome settings I believe I have all the visible options set correctly and while under X it does seem to stay alive.

However last night I halted the X server and logged out of the command line (not using gdm) and closed the lid with some background tasks running. When I opened the lid this morning it took several seconds while the cursor flashed in the upper lefthand part of the screen and then it displayed the command line login. It appears the box was in some kind of power management state and all the work I had expected to finish over night was idle and only started running again at that point.

I want to turn off absolutely all power management on this box. I don't want CPU scaling, I don't want sleep, suspend, hibernate, etc. whether running X server or command line. I want this box to run like a server. Laptop is just a state of mind.

Message to moderators: Several of my questions have been closed and marked already answered elsewhere. And several posts I found searching here were also closed the same way. But in all those cases you did not provide links to similar/identical posts and answers.

It is extremely unhelpful (frustrating!) for you to close questions without pointing us in the right direction. I am new to Fedora after 15 years of Slackware and various BSD and it is very frustrating to go for days with a broken box and not much help.

Please, if you are going to close posts then please point us to the answers because if I'm posting a question here it means I spent time searching but couldn't find the answer. It doesn't mean the answer isn't here, but I didn't find it.

Thank you,

Bill Williams

edit retag flag offensive close merge delete

Comments

would it be easier to kill power management at the BIOS in the motherboard, and not worry about the OS having to do it?

steveebey73742 gravatar imagesteveebey73742 ( 2018-01-04 23:04:01 -0600 )edit

@steveebey yes, I believe it would so I have turned off ACPI as much as I can see in the BIOS. I am not sure it helped! This is a new box and I am new to fedora, so there is a steep curve for me here.

At first with ACPI set to defaults and the default gnome settings, my box would suspend or hibernate (not sure which term(s) are correct) but I could not ever get it to come out of that state and would have to power it off. I read other posts about people not being able to resume with f27. Then I changed the gnome settings and when in gnome it stopped suspending and was ok.

billwilliams gravatar imagebillwilliams ( 2018-01-04 23:39:47 -0600 )edit

@steveebey I will look over the BIOS again but I got the feeling Fedora was doing some power management even with ACPI disabled... is this possible? Totally new stuff to me as I have run ACPI off with any laptop I have ever had but now everything seems different ;-) Thank you for your help on all these issues! It's so difficult getting to know a new world (systemd, new distro). Bill

billwilliams gravatar imagebillwilliams ( 2018-01-04 23:41:39 -0600 )edit

@steveebey I went through the BIOS today and I could not find anything that looked relevant. After I get the nVidia situation sorted so I can run with the current kernel I'll try to deal with this next. Thanks again for your help! Enjoy the rest of the weekend, Bill.

billwilliams gravatar imagebillwilliams ( 2018-01-06 15:48:56 -0600 )edit

Try turning off suspend when lid is closed. Edit /etc/systemd/logind.conf and add/change HandleLidSwitch=lock.

martrs gravatar imagemartrs ( 2018-04-10 02:52:45 -0600 )edit