Ask Your Question
0

phpmyadmin error

asked 2018-01-10 03:02:26 -0500

bionan2017 gravatar image

Hello, I installed phpmyadmin and when I try to access via localhost / phpMyAdmin the following error message appears:

Warning: require_once (): It is not safe to rely on the system's timezone settings. You are * required * to use the date.timezone setting or the date_default_timezone_set () function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /usr/share/phpMyAdmin/libraries/common.inc.php on line 492

Parse error: syntax error, unexpected '@' in /usr/share/phpMyAdmin/libraries/common.inc.php on line 492

I'm using Fedora 27 and PHP version 7.1.12

Thanks for any help

edit retag flag offensive close merge delete

Comments

Hi, How did you install phpMyAdmin? That one looks like an version incompatibility error.

casep gravatar imagecasep ( 2018-01-10 09:51:24 -0500 )edit

What is at line 492 in that file? It sounds like you are expected to edit that and put the right timezone in. Or you didn't do the install correctly and that was supposed to be modified during the install process.

ssieb gravatar imagessieb ( 2018-01-10 14:06:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-11 05:17:13 -0500

bionan2017 gravatar image

Hello, It was a problem with the PHP version. phpmyadmin requires PHP> = 5.5 and the version I had installed on my computer was PHP 5.46. Just updating the PHP version and everything worked fine. Thanks to everyone who commented.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-10 03:02:26 -0500

Seen: 403 times

Last updated: Jan 11