Fedora 27 (Linux in general) - not connection to mac filtered wifi

asked 2018-01-25 10:33:39 -0500

updated 2018-02-13 08:59:36 -0500

Hello community,

i got the problem on my acer aspire 575g that i cannot connect to the wifi @ my school which has a mac filter on. It first asks me a few times to type in the password and after a while i kinda connect but no internet access, it just shows a questionmark. I already tried to create the file "/etc/NetworkManager/conf.d/100-disable-wifi-mac-randomization.conf" with the content:

[connection]

wifi.mac-address-randomization=1

[device]

wifi.scan-rand-mac-address=no

But without luck, still can't connect. This is happening on any linux distro, tried ubuntu, debian, fedora, suse. THO! The wifi connection works on Windows 10. This is so weird, maybe there is a driver problem?(Qualcomm Atheros QCA9377)

I really need help here!

edit retag flag offensive close merge delete

Comments

You shouldn't need that file. The first option I think is wrong anyway and deprecated. The second option should be unnecessary because it only uses random mac addresses for scanning, not for connecting. Have you checked that the mac address is the same in windows and Fedora?

ssieb gravatar imagessieb ( 2018-01-26 16:20:09 -0500 )edit

yep, it's the same mac-address in windows and linux. I tried connecting to the network with the laptop of a friend (has the same one as me) and it didn't work either. Others with linux can connect to the network.

gitgudgithub gravatar imagegitgudgithub ( 2018-02-13 08:58:22 -0500 )edit