Ask Your Question
1

Boot from Fedora 27 installed in an internal mSATA SSD

asked 2018-01-31 17:00:57 -0600

alfC gravatar image

updated 2018-02-06 14:24:16 -0600

I have a Dell Inspiron 17R 5720, which has a 64GB PCIe mSATA internal SSD (small chip connected inside the laptop, in a small pci slot). After installing Fedora (I tried automatic partition), I cannot boot from this disk, I get a black screen with the message "Operation(sic) system not found".

It seems that it is not able to boot from this disk. Is it because it is a secondary disk?

I tried combintions of UEFI on/off and secure boot on/off. Of course everything works if I have a bulky SSD connected to the SATA connectors. But I want to install the operating system in the internal 64GB PCIe mSATA SSD. (and have /home in the 500GB SATA SSD).


This is what I ended up doing, which is not ideal. This is the only combination I was able to make it work. Suggestions are welcomed, although it maybe too late to change something without breaking the installation.

image description

image description

edit retag flag offensive close merge delete

Comments

1

Have you changed the BIOS boot setting so that you boot from the small PCI SSD, not the SATA one?

Period22 gravatar imagePeriod22 ( 2018-02-01 01:01:55 -0600 )edit

Have you made sure you installed the bootloader onto that drive?

florian gravatar imageflorian ( 2018-02-01 04:16:37 -0600 )edit

Sounds to me like you are having an issue with boot sequence especially since boot manager is able to find OS on your ATA device. I would check your CMOS settings and make sure you have your PCIe SSD set to boot prior to any other devices. Is the PCIe card showing up in BIOS-UEFI? Also are are you currently running another OS on this machine?

fidelio gravatar imagefidelio ( 2018-02-02 23:29:05 -0600 )edit

@florian I wouldn't know how to install the bootloader in that drive. I didn't see the option in the anaconda partitioning utilities. And if it is necessary I don't know why Fedora doesn't do it automatically.

alfC gravatar imagealfC ( 2018-02-06 02:33:28 -0600 )edit

There is no option to change the boot sequence between "hard drives". CMOS only gives the option "boot from hard-drive". There is no mention to the PCIe card in the BIOS, I looked everywhere. I have no other OS in the system. As I said, I did exactly the same steps using only the PCIe card and only the SATA drive. It only boots with the later. At the end what I did was to put a /boot parition in the SATA (2MB) (together /home) and a / in the PCIe card. Which is no ideal because I will not be able to remove the SATA and expect the PCIe to work by itself.

alfC gravatar imagealfC ( 2018-02-06 02:37:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-02-01 04:52:08 -0600

mikkol gravatar image

Your error message suggests you are booting in CSM mode. When you install Fedora, it is important that you have booted the installer in the same mode you want to boot the operating system in: if you boot in UEFI mode, the installer will make an UEFI install; if you boot in CSM mode, the installer will make a CSM install. The current standard is UEFI. Do note that if you installed it in UEFI mode and then change the firmware (you may call it BIOS) settings to boot in CSM (Legacy/etc.) mode, the UEFI boot loader will not be found or detected.

In addition, some poorly written firmware implementations do not support correct storage of EFI boot order (for example, Supermicro motherboards seem to overwrite the EFI boot order at each reboot), so your computer may well have forgotten the boot order.

Your reference to "secondary disk" dates back to the 90s. We no longer have primary/secondary master/slave disks but just disks in different SATA/PCIe/SAS/etc channels. You set the boot device, and nothing is "secondary."

Boot your system with a live OS downloadable from here and then run disks in Gnome. This way you will see the type of partitioning you have on your disk and can decide if your initial setup was done with for CSM or UEFI booting, and then change your firmware settings to the corresponding option.

Better yet, if your setup is a new one, just force UEFI booting in your firmware settings, boot the live OS above and install Fedora again using the live OS you downloaded.

edit flag offensive delete link more

Comments

I don't know what is going on. I tried all the combinations, I installed in the SSD chip and in the SSD bulky drive and it only worked when I did it in the SSD bulky. At the end what I did was to add manually a small /boot partition (and /home) in the bulky drive and / (root) in the SSD ship. This is the only way I was able to make it boot. This sort of defeats the purpose becuase I won't be able to put this /boot /home disk in another computer. Also, unfortunatelly I installed everything by now, maybe next time. Something broke because a few years ago I used to separe / from /home easily.

alfC gravatar imagealfC ( 2018-02-01 05:09:45 -0600 )edit

Now with LVM, UEFI and UEFI secure boot it is a mess.

alfC gravatar imagealfC ( 2018-02-01 05:10:47 -0600 )edit
1

Can you please check your disk layout with the Disks utility? It will tell you if you have an EFI partition or not (needed for UEFI boot, irrelevant for CSM) and if the partition scheme is MBR or GPT (shouldn't matter for UEFI, some firmware implementations require GPT).

Creating the partitions manually does not prevent you from moving the OS to another computer. The beauty with Fedora is that you can take the disk from one HW to another and it most likely will work.

Finally, the Fedora installer is happy to install on a PCIe/NVMe device but your firmware might not know how to boot from it.

mikkol gravatar imagemikkol ( 2018-02-02 02:38:46 -0600 )edit

@mikkol, thank you for your help. "Disks" doesn't mention the word "EFI" anywhere that I can see. See the new screenshots I put in the question. Maybe I will be able to boot in other computer if from Disks, I mark the PCIe partition bootable? or is it too late. Yes, it maybe a hardware problem, it looks like my Dell doesn't know how to boot from the PCIe.

alfC gravatar imagealfC ( 2018-02-06 02:42:12 -0600 )edit
1

Your disk is not a PCIe disk. It is an mSATA disk. Instructions for setting up the system for booting from an mSATA disk can be found here.

Note that the beginning of the instructions talk about adjusting settings that are available only through a preinstalled copy of Windows. Further down the thread, you will see instructions about adjusting the BIOS settings.

mikkol gravatar imagemikkol ( 2018-02-06 07:50:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-01-31 17:00:57 -0600

Seen: 655 times

Last updated: Feb 06 '18