Ask Your Question
1

[solved] xscrensaver doesn't work

asked 2018-02-08 10:27:46 -0500

toddandmargo gravatar image

updated 2018-02-13 16:19:51 -0500

Hi All,

Fedora 27, x64
Xfce 4.12
xscreensaver-gl-base-5.38-1.fc27.x86_64
xscreensaver-5.38-1.fc27.x86_64
xscreensaver-extras-base-5.38-1.fc27.x86_64
xscreensaver-gl-extras-5.38-1.fc27.x86_64
xfce4-screenshooter-plugin-1.8.2-9.fc27.x86_64
xscreensaver-base-5.38-1.fc27.x86_64
xscreensaver-extras-5.38-1.fc27.x86_64
xfce4-screenshooter-1.8.2-9.fc27.x86_64

I can fire up Screen Saver preference, I can preview my screen saver, I set it for five minutes, no screen saver. HOW CAN I LIVE WITHOUT MY BOUNCING COWS!!???

How do I get my screen saver to work. It did work in FC26.

Many thanks, -T

edit retag flag offensive close merge delete

Comments

Are you running Wayland now?

ssieb gravatar imagessieb ( 2018-02-08 14:24:45 -0500 )edit

This was installed from the Xfce 4.12 spin. Xfce does not support Wayland, so Wayland was never installed.

toddandmargo gravatar imagetoddandmargo ( 2018-02-09 16:08:32 -0500 )edit

sounds like a bug report, for xfce. I installed xscreensaver from source, in f27, with cinnamon, then make sure in the control settings to disable any native desktop screen saver, and make sure the autostart for the daemon for xscreensaver is setup properly.

steveebey73742 gravatar imagesteveebey73742 ( 2018-02-10 14:13:07 -0500 )edit

No response from Xfce. So I posted to Red Hat:

https://bugzilla.redhat.com/show_bug.cgi?id=1544297
toddandmargo gravatar imagetoddandmargo ( 2018-02-11 19:34:05 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2018-02-12 00:34:21 -0500

toddandmargo gravatar image

updated 2018-02-13 04:13:09 -0500

Turning off xfce4-power-manager's "presentation mode" fixed the issue

Opened "https://bugzilla.xfce.org/show_bug.cgi?id=14210"

[solved]

edit flag offensive delete link more

Comments

since you found a solution, update the topic title, to show solved, so others with a similar issue may benefit.

steveebey73742 gravatar imagesteveebey73742 ( 2018-02-12 10:10:19 -0500 )edit

I would love to. How?

toddandmargo gravatar imagetoddandmargo ( 2018-02-12 11:29:36 -0500 )edit

edit button, on your original question, Just put [solved] in the topic, at the end. I was able to retag it, to add a solved tag, but you should be able, as the OP to edit the topic name.

steveebey73742 gravatar imagesteveebey73742 ( 2018-02-12 13:17:29 -0500 )edit

Okay. Did I do it right?

toddandmargo gravatar imagetoddandmargo ( 2018-02-13 04:13:42 -0500 )edit

No, the topic still does not show [solved] in the topic line.

steveebey73742 gravatar imagesteveebey73742 ( 2018-02-13 08:49:38 -0500 )edit
0

answered 2018-03-02 12:45:21 -0500

toddandmargo gravatar image

Followup:

Presentation mode drives me nuts when it starts and does not tell me it is enabled (it messes up my screensaver).

https://bugzilla.xfce.org/show_bug.cg...

So I wrote myself the following and placed it in start up:

<code PresentationMode.sh>
#!/bin/bash

sleep 5s

# ture|false
PresentationMode=$(xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/presentation-mode)

if [ "$PresentationMode" == "true" ]; then
   notify-send --urgency=normal \
   --icon /usr/share/icons/oxygen/base/64x64/mimetypes/x-office-presentation.png \
   --expire-time 0  Xfce4-power-manager  "Presentation Mode is Enabled"
fi
</code>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-08 10:27:46 -0500

Seen: 168 times

Last updated: Mar 02