Ask Your Question
0

Low framerate/lag with external screen after resume

asked 2018-02-16 09:09:42 -0600

theonlyandy gravatar image

I'd like to analyze my issue further but I don't know how, maybe you can point me in directions?

I'm using a rather big screen with 3440×1440 on Mini-DP, which Wayland can not handle together with my internal screen on my Inter graphics card (there's blackouts). That's why I'm using the external screen only.

Everything works smoothly, dragging windows around even while video is playing is no problem at all.

Now, when I put my laptop to sleep and resume (maybe on battery), suddenly it feels laggy. I notice when moving windows around, and that I have difficulties hitting buttons with the mouse.

When I unplug the external screen, on my internal 1600×900 it feels smooth again. I'm not sure whether re-plugging the external one solved the issue, since it's a quite subtle effect.

I'd like to know how I can measure framerate, to make sure what the problem actually is. I wanted to file a bug report in Gnome bugs, but I don't know which package to report to.

lspci lists my graphics controller as

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

I'm having a T430i, which should have a Intel HD Graphics 4000, and a Intel® Core™ i5-3320M CPU @ 2.60GHz × 4

Maybe it also has to do with Screen Settings lost after logging in from lock screen?

Thanks for help!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-06-15 04:35:04 -0600

Although your question is months old - I have been suffering from this defect too until now. I was able to rectify the symptoms by carrying out the following steps..

This solution focuses on issues surrounding the CPU management itself - symptoms of which would be: opening top/htop shows no high memory or CPU usage upon resume but things are still lagging.

Disclaimer: Hardware tweaks from software can damage the device so exercise extreme caution. I exempt myself from any ill effect befalling your machine should this go horribly wrong- you have the controls. Back up your data if super cautious.

Available scaling settings (governors) can be found within the /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors file

1) Verify the current power setting of the CPU:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

If the output shows any of the cpus running at something over than performance (e.g. powersave) then continue, otherwise stop here as this solution may not help you.

2) Change the power setting of the CPU:

echo "performance" | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

The performance of the laptop should now be back to where it should be. The ultimate solution would be for RedHat/Fedora to release a patch so that laptops automatically choose this mode upon resumption from suspend - if the check is installed it could be failing because of some confusion over the battery state e.g. if the laptop is on a dock.

References:

  1. https://www.gamingonlinux.com/article...
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-02-16 09:09:42 -0600

Seen: 83 times

Last updated: Feb 16