Upgrade to Fedora 27 - no webkitgtk - what are my options?

asked 2018-02-17 09:55:14 +0000

becks21 gravatar image

Hi there,

planning to upgrade to Fedora 27 I noticed that webkitgtk has been removed for security reasons. I still would like to use a sysml modelling tool called Modelio, which unfortunately depends on webkitgtk..

What are my options?

Thx & cheers

edit retag flag offensive close merge delete


I would try this:

  1. download webkitgtk-2.4.9-1.el7.src.rpm for RHEL7
  2. sudo dnf builddep webkitgtk-2.4.9-1.el7.src.rpm
  3. rpmbuild --rebuild webkitgtk-2.4.9-1.el7.src.rpm
  4. wait, wait, wait....
  5. sudo dnf install webkitgtk-2.4.9-1.fc27.x86_64.rpm
fcomida ( 2018-02-17 13:35:05 +0000 )edit

Thx a lot for your suggestions.. tried but upon rpmrebuild (in a fresh Fedora 27 VM) I get the error "configure: error: Compiler GCC >= 4.7 or Clang >= 3.3 is required for C++ compilation" although I have gcc installed, "gcc -v" gives: "gcc version 7.3.1 20180130 (Red Hat 7.3.1-2) (GCC)"

becks21 ( 2018-02-17 19:44:17 +0000 )edit

I tried it just for testing... rpmbuild actually passed configuration phase and started building it. Make sure you have gcc-c++ installed. Compilers usually aren't listed as dependencies.

fcomida ( 2018-02-17 20:11:46 +0000 )edit

and again thank your very much.. cant believe I was so blind to not see gcc-c++ wasnt installed :D its compiling now since 15 minutes..

becks21 ( 2018-02-17 21:20:43 +0000 )edit

@becks21 wait, wait, wait. Maybe a better option would be building it on copr...

fcomida ( 2018-02-17 21:31:18 +0000 )edit