Ask Your Question
2

The pc freezes after login, have to reboot for successful start up. RPMfusion, nvidia drivers, gdm, Gnome Workstation.

asked 2018-02-17 09:36:30 -0600

christianbueno gravatar image

updated 2018-04-19 16:12:31 -0600

My system , desktop

  • Processor: Intel Core i5-4430 3GHz.
  • ram: 16GiB.
  • (sda) ssd disk:Kingston ssdnow v300 240GB.
  • (sdb) hard disk: 2 TB.
  • Fedora 27 workstation (gnome).
  • nvidia drivers by rpmfusion.
  • GeForce GT 610.

Operating systems

  • 1st installed: windows 10.
  • 2nd installed: Fedora 27 workstation

SDA

  • sda2 /boot/efi
  • sda1, sda3, sda4 , windows10 , 110GiB
  • sda5 : / , fedora , 110GiB

SDB

  • sdb1 : shared document , ntfs , 800GiB
  • sdb2 : /home , fedora , 150GiB
  • sdb3 : swap , 24GiB

RPMfusion repositary enabled
After install ndivia drivers

$ sudo dnf install xorg-x11-drv-nvidia akmod-nvidia
$ sudo dnf update -y
$ reboot

After reboot the pc in any kernel selected on the grub menu the problems is similar:

  1. The Plymouth doesn't appears.
  2. After login the screen freezes , mouse freeze, CTRL+ALT+F2 doesn't work.
  3. I have to reboot the pc
  4. The second time the Plymouth does appears.
  5. After login screen the pc work well and show the desktop.
  6. If reboot the pc or turn off and turn on, the cycle is repeated. (step 1)

Is anybody there faced this issue?
How can we check problems about it?

Thanks in advances, any suggestion is well received.

edit retag flag offensive close merge delete

Comments

I had to uninstall nvidia(provided by rpmfusion repository) drivers sudo dnf remove xorg-x11-drv-nvidia , the problem was fixed. I tried install the drivers by following this guide (if-not-true-then-false), the driver was installed but after login the screen is black , no mouse, like problems in any 3 kernels(4.15.3 , 4.14.18 , 4.14.16 ), had to unistall the proprietary nvidia drivers again and install the default free and open source nouveau drivers. Now with open-source drivers the problem was fixed.

christianbueno gravatar imagechristianbueno ( 2018-02-18 15:13:24 -0600 )edit

But you know the performance is better with proprietary nvidia dirver, what can we do? I was working/ learning web development and sometimes with some open programs the pc performance was slow.

christianbueno gravatar imagechristianbueno ( 2018-02-18 15:24:21 -0600 )edit

6 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-12 13:42:55 -0600

christianbueno gravatar image

updated 2018-07-12 19:15:37 -0600

I have tested the last week installing fedora 28 workstation on my SSD along side windows 10, my steps for installing rpmfusion nvidia driver was:

On the login screen(gdm) switched from Gnome(wayland) to Gnome with xorg.

I Installed the free and non-free repositories(fedora 22 and later)

$ sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Then updated the pc

$ sudo dnf update

Then uncommented "WaylandEnable=false" on /etc/gdm/custom.conf

Then rebooted the pc

Then I installed the rpmfusion nvidia driver (current GeForce/Cuadro/Tesla ), as my question inform I have a GeForce GT610 graphic card.

$ sudo dnf install xorg-x11-drv-nvidia akmod-nvidia

After reboot the pc, I can't pass the login screen (GDM) sucessfully, the screen get the same color of the GDM background and stuck it there forever. Any of the tty console works (ctrl+alt+fn). All kernel option that is showed by the grub2 have the same result.

To fix this problem you can change runlevel to 3 on GRUB2 (this modification is not permanent), now you will be inside your pc without a GUI interface, there you have to login with your user account name and your password. Now you can uninstall the nvidia driver, after that reboot the pc.

$ reboot

Now you will have the open graphic driver installed and the pc will be usable. If you don't want uninstall rpmfusion nvidia driver follow the steps below.

But now you can successfully solve the GDM issue.

The solution is change gdm(display manager) to another , for example lightdm. You must run your pc without a GUI interface, you could do that by change run level to 3 on GRUB2.

First you have to change runlevel to 3
Login with your user name account and password.
Then install lightdm

$ sudo dnf install lightdm

Now disable gdm.service and enable lightdm

$ sudo systemctl disable gdm.service
$ sudo systemctl enable lightdm

Stop gdm and start lightdm

$ sudo systemctl stop gdm
$ sudo systemctl start lightdm

Then reboot your pc

$ reboot

thanks pals, greetings from Ecuador, you could use open drivers but if you like to install proprietary driver , it is possible on fedora 28 workstation.

edit flag offensive delete link more
1

answered 2018-04-08 12:01:33 -0600

kwizart gravatar image

Thx for your feedback. For the record, newer drivers from RPM Fusion will disable wayland in gdm until the situation improves. (specially when mutter will enable EGLStream as reported in https://bugzilla.redhat.com/show_bug.... ).

Everything should work as appropriate by default. (if not, please report to https://bugzilla.rpmfusion.org )

edit flag offensive delete link more
0

answered 2018-07-06 19:43:53 -0600

christianbueno gravatar image

hello pals, on fedora 28 workstation , gdm problems persist, I am now in a fresh installation of fedora 28 workstation with open graphic driver.

[harvey@localhost ~]$ uname -a
Linux localhost.localdomain 4.17.3-200.fc28.x86_64 #1 SMP Tue Jun 26 14:17:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
edit flag offensive delete link more
0

answered 2018-05-04 20:42:31 -0600

christianbueno gravatar image

The problem persist on Fedora 28. On fedora 28 KDE plasma spin all work much better.

edit flag offensive delete link more
0

answered 2018-04-27 09:14:37 -0600

christianbueno gravatar image

new report: Successful boot with new kernel 4.16.3-200.x86_64 on fedora 27 KDE plasma spin.

edit flag offensive delete link more
0

answered 2018-03-19 17:47:35 -0600

christianbueno gravatar image

updated 2018-03-19 20:44:40 -0600

hello pals, I found a temporary fix.
edit the file /etc/gdm/custon.conf from

WaylandEnable=false

to

#WaylandEnable=false

Now I have a slow GDM login screen, but I prefer this lesser evil than pressing the "reset button" again and again.
It only work with the default kernel 4.13.9 , with newest kernel it doesn't work , after login screen the windows get black.

edit flag offensive delete link more

Comments

On fedora 27 KDE plasma spin I don't have any problems with nvidia drivers from rpmfusion , the pc boot on all kernes very well. Hooray

christianbueno gravatar imagechristianbueno ( 2018-03-19 23:45:23 -0600 )edit

On fedora KDE spin I only have had to reinstall xorg-x11-drv-nvidia akmod-nvidia only one time. Very tiny problems in comparison to fedora-workstation and gdm problems.

christianbueno gravatar imagechristianbueno ( 2018-04-18 22:46:43 -0600 )edit

New report: Hello pals, Successful boot. fedora 27 KDE plasma spin , 4.15.17-300.fc27.x86_64. If you want avoid nvidia drivers problems I suggest you use F27 KDE spin. I like gnome , hope GDM problems will be fixed

christianbueno gravatar imagechristianbueno ( 2018-04-19 08:42:55 -0600 )edit

nvidia drivers are fine, GDM is the problem. I use cinnamon spin with lightdm, since fedora 24, and use proprieatry nvidia with dkms to manage kernel updates. I have 0 problems, and am using latest drivers 396.18 on my GeForce GTX 970 4Gig card. I am on fedora 27 with kernel 4.15.17-300.fc27.x86_64 nvidia 396.18

steveebey73742 gravatar imagesteveebey73742 ( 2018-04-19 17:58:32 -0600 )edit

Same in my case xorg-x11-drv-nvidia version 390.48-1.fc27

christianbueno gravatar imagechristianbueno ( 2018-04-20 11:29:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-17 09:36:30 -0600

Seen: 1,921 times

Last updated: Jul 12