Ask Your Question
2

gdm crashes on login

asked 2018-02-28 15:19:11 -0500

msum gravatar image

updated 2018-03-01 04:07:28 -0500

I have a NVIDIA GeForce GTX 1060 and I'm using a proprietary NVidia driver. My recent problems started (surprise, surprise) after a recent update of the drivers.

At the moment, I cannot login using GDM - after entering the password and hitting "Login", it stays on a blank grey screen. The result is the same no matter whether using Wayland or Xorg. However, a couple of days before, I could still sometimes login and the results were different: an Xorg session worked without issues, while the Wayland session was extremely slow and the system monitor showed very high CPU load (70~80%). Since then, I've reinstalled the xorg-* packages several times, but I didn't install anything new or remove anything. I also kept installing updates, but as far as I've seen, they didn't involve anything video-related.

Here is my journalctl -xb output from such crashed session (obtained via ssh, as Ctrl+Alt+F2 doesn't work either). Some of it is in Polish, but I think the relevant parts are in English. The disaster seems to start at line 4889, but maybe there are some suspicious symptoms earlier.

Interestingly, if I bypass GDM and start the i3 window manager with startx, everything works normally. So it's not directly a video issue, rather something with GNOME.

edit retag flag offensive close merge delete

Comments

Please use fpaste instead of whatever that horrid upload site is. Asking people to wait 50 seconds and look at ads before they can see your log files to offer you help is … yeah. Use fpaste.

Aeyoun gravatar imageAeyoun ( 2018-02-28 15:35:59 -0500 )edit

Thank you, didn't know about that. I've updated the link. No need to downvote.

msum gravatar imagemsum ( 2018-02-28 16:13:04 -0500 )edit

Where do you get Nvidia driver from, their website?

ozeszty gravatar imageozeszty ( 2018-02-28 18:23:42 -0500 )edit

The driver comes from rpmfusion-nonfree.

msum gravatar imagemsum ( 2018-03-01 03:24:20 -0500 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2018-03-01 04:05:04 -0500

msum gravatar image

updated 2018-03-08 13:04:36 -0500

Setting nvidia-drm.modeset=0 in GRUB solves the issue.

edit flag offensive delete link more

Comments

Doing that got me slightly further than before, but it still crashes. This time, rather than freezing on a grey screen, it freezes on a black screen.

Louis gravatar imageLouis ( 2018-03-10 02:45:39 -0500 )edit

Are you sure that GDM is using Xorg? You can uncomment the line WaylandEnable=false in /etc/gdm/custom.conf to make sure of that. Does X work fine without a login manager like in my case?

msum gravatar imagemsum ( 2018-03-24 08:15:52 -0500 )edit
1

answered 2018-03-27 14:04:14 -0500

Tigro gravatar image

Try to do this:

  1. add nvidia-drm.modeset=0 то grub config last kernel linux line (and to /etc/default/gub too).
  2. Comment (yes COMMENT) WaylandEnable=false in /etc/gdm/custom.conf
  3. reboot.
edit flag offensive delete link more

Comments

Great, thanks. This was exactly what solved my problem!!!

beacher_pille88 gravatar imagebeacher_pille88 ( 2018-05-05 03:22:51 -0500 )edit

This is exactly the same issue I'm experiencing, it seems starting gdm on Xorg causes the session to crash on login.

brozzsama gravatar imagebrozzsama ( 2018-05-10 11:23:49 -0500 )edit

I was helped by this advice: https://ask.fedoraproject.org/en/ques... Downgrade from 3.14.1-24.fc28 to 3.14.1-21.fc28

SpyWSamara gravatar imageSpyWSamara ( 2018-05-24 12:47:37 -0500 )edit
1

answered 2018-02-28 16:43:04 -0500

Aeyoun gravatar image

updated 2018-02-28 16:45:29 -0500

This is your error right here:

failed to take device /dev/dri/card0: Invalid argument

This is usually accompanied by a more specific error, but there really isn’t anything more in your logs to clarify the issue. It means that a feature that GNOME expects of your graphics card that isn’t supported by the driver.

You can try to disable the proprietary NVIDIA driver and try the open source Nouveau drivers instead. The opposite of what you’ve doing now, in other words. (Linux compatibility for NVIDIA is poor because the Kernel gets no support or even documentation from NVIDIA.)

edit flag offensive delete link more

Comments

I'm afraid GTX 1060 won't be usable with nouveau, yet.

ozeszty gravatar imageozeszty ( 2018-02-28 18:25:26 -0500 )edit
1

It seems to work with nouveau for now. However, it's not a permanent solution for me, because I need CUDA for my work (and AFAIK running CUDA on nouveau is not possible).

Is there any way to figure out which feature it is and whether I can disable something in GNOME that requires it?

msum gravatar imagemsum ( 2018-03-01 03:39:38 -0500 )edit

@msum Not that I know. Maybe you should investigate alternatives to NVIDIA technologies? It’s not a good match for any Linux environment.

Aeyoun gravatar imageAeyoun ( 2018-03-01 03:48:21 -0500 )edit
0

answered 2018-03-04 17:28:16 -0500

Please check Howto/NVIDIA on rpmfusion.

https://rpmfusion.org/Howto/NVIDIA#Cu...

If you don't know about rpmfusion,Please check here.

https://rpmfusion.org/Configuration

I have Gforce 7600GS. Same issue happened when updated to 26.I couldn't login from graphic interface. It freeze with black screen.

It works fine for me.

edit flag offensive delete link more

Comments

So how did you fix the issue?

msum gravatar imagemsum ( 2018-03-08 13:04:00 -0500 )edit

I've tried the above but my screen is super slow...having the same issue with proprietary and non-proprietary driver.

kiren gravatar imagekiren ( 2018-07-10 10:33:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-02-28 15:19:11 -0500

Seen: 2,165 times

Last updated: Mar 08