Ask Your Question
1

Random Wi-Fi failure on Surface Pro 4

asked 2018-03-12 22:07:04 -0600

techciel gravatar image

updated 2018-03-26 01:52:52 -0600

I recently installed Fedora 27 on my Surface Pro 4 but Wi-Fi didin't work normally.

The Wi-Fi adapter is Marvell Technology Group Ltd. 88W8897 [AVASTAR] 802.11ac Wireless.

My first startup is successful with Wi-Fi working. However, after a restart it couldn't detect any available network and failed to connect saved network.

I tried to restart again and again. Sometimes Wi-Fi works well while sometimes fails to connect. If it failed, the only solution found is to restart again. Even if it started with a successful connection, the connection could go down anytime.

I tried to replace firmware in /lib/firmware/mrvl/ with various versions but it doesn't work at all.

Does someone have same problem like this or have some ideas? Any help will be helpful!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-03-13 11:49:44 -0600

Aeyoun gravatar image

This is not a problem unique to Fedora, but to the 88W8897 chipset. From what I can gather by searching the web for a few minutes; the problem seems to be that the adapter fails to wake up from powersave mode. You can try disable power management for the WiFi adapter by following the instructions under the ‘Permanently disable power saving with NetworkManager’ headline.

Issues with powersave mode are quite frequent on Linux because different device manufacturer often implement custom changes to component’s power management. The generic drivers in the Linux kernel aren’t aware of the device specific requirements to get it to work properly.

edit flag offensive delete link more

Comments

I've tried many ways and found this one working. [device] wifi.scan-rand-mac-address=false The Wi-Fi is now always working on startup but still go down while using.

I'll try this and thanks so much for helping! :)

techciel gravatar imagetechciel ( 2018-03-14 03:06:18 -0600 )edit

I am having the same issue and I am running a surface book. Wifi will work at startup and then drop out randomly and require a reboot.

I've tried changing the config file and it doesn't seem to help, but I haven't looked into updating the firmware.

Did this work for you?

tonywithani gravatar imagetonywithani ( 2018-04-16 21:54:05 -0600 )edit
0

answered 2018-03-14 18:23:22 -0600

techciel gravatar image

updated 2018-04-19 01:00:45 -0600

I'm answering myself with my current solution :

Step 1: update firmware

Update firmware to an appropriate version. Now version newer than V15.68.7.p66(till current newest version V15.68.7.p154) will cause poor speed.

git clone git://git.marvell.com/mwifiex-firmware.git
git reset --hard [commit-id-of-an-appropriate-version]
sudo mkdir -p /lib/firmware/mrvl/
sudo cp mwifiex-firmware/mrvl/* /lib/firmware/mrvl/

Step 2: change network manager config

Add the following config

[connection]
wifi.powersave = 2
[device]
wifi.scan-rand-mac-address=false

to /etc/NetworkManager/NetworkManager.conf

Step 3: reboot

After this fix, I'm not getting Wi-Fi failure on startup anymore and it didn't down while using.

Thanks to @Aeyoun and https://github.com/jakeday/linux-surface .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-12 22:07:04 -0600

Seen: 579 times

Last updated: Apr 19