Ask Your Question
0

fedora 27 wifi

asked 2018-04-01 12:39:05 -0500

I have installed Fedora 27 on a HP probook 6475b with widows 7 already installed. Installation process was Ok ... main problem the wifi card is not recognized, model is Broadcom BCM943228HM4L, I can connect to Internet only by cable.

Not much experience with Linux, I tried to follow the procedure described here: https://www.tekbyte.net/install-broad... but still no result and wifi card is still not recognized..

Thanks for any help

edit retag flag offensive close merge delete

Comments

Please post output of dmesg: run dmesg | fpaste and copy the link. sudo dnf install fpaste if fpaste isn't installed.

fcomida gravatar imagefcomida ( 2018-04-01 14:06:18 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-04-01 14:15:46 -0500

MaJa gravatar image

hi you can try these steps.

open terminal and type lspci command to find out your wireless card name.

sample output :

00:00.0 Host bridge: Intel Corporation 7th Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 7th Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C810 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C816 Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C810 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 85492G Gigabit Network Connection (Lewisville) (rev 04)
03:00.0 **Network controller: Intel Corporation Xentrino Advanced-N 9205 [Delta Peak] (rev 38)**

Next you need to enable RPMfusion repos, ignore if already installed.

Sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

perform system update by using dnf update command and reboot the system to ensure latest kernel is installed.

next install this package.

sudo dnf install kmod-wl

once install is completed reboot the system. you should now be able to select network on network manager option.

edit flag offensive delete link more

Comments

Reply to fcomida : here is the link for dmesg | fpaste :

https://paste.fedoraproject.org/paste...

giovannisignor gravatar imagegiovannisignor ( 2018-04-02 11:31:16 -0500 )edit

Thanks a lot to Maja, the procedure he suggested solved the problem and now wifi connection works great...

giovannisignor gravatar imagegiovannisignor ( 2018-04-03 11:29:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-04-01 12:39:05 -0500

Seen: 218 times

Last updated: Apr 01