Ask Your Question
-1

Monitor turns on by itself

asked 2018-04-06 04:16:28 -0500

cpetepf gravatar image

My monitor keeps turning on by itself 3 or 4 per hour at night. Displays the splash screen then turns off. Keeps waking me up. I have fedora 27 installed. The only setting I have changed recently is accessibility , I turned on large text. I don't see how that would cause the monitor to come on randomly. Any help is appreciated. Thank you.

edit retag flag offensive close merge delete

Comments

Which desktop environment are you using? Gnome?

mathiasb gravatar imagemathiasb ( 2018-04-06 04:49:31 -0500 )edit

If your compute is powered off - how would that behaviour be related to Fedora or any other operating system?

florian gravatar imageflorian ( 2018-04-06 10:54:49 -0500 )edit

The desktop environment I am using is gnome version 3.26.2. The computer is not powered off, it is on idleing. The monitor is off, being managed by the os.

cpetepf gravatar imagecpetepf ( 2018-04-06 17:30:16 -0500 )edit

What do mean by idleing? It's on, right, with a screen saver on, or is it in standby?

florian gravatar imageflorian ( 2018-04-08 16:13:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-08 03:47:31 -0500

hello gravatar image

There may be slight movements with the mouse/trackpad. Disable the mouse before you leave next time. Perhaps that will fix it.

Maybe there are some weird notifications getting triggered? Try checking logs and report back.

edit flag offensive delete link more

Comments

I agree with you that there slightly movements because I have a moving blanket covering my desktop as not to scratch the surface. Maybe the fibers of the blanket are triggering the laser mouse. It's quite an old mouse maybe 15 years, it's a Logitech. But would that be enough to wake the computer?

I checked the logs (dmesg & journalctl) right after the screen would wake up. I did not notice anything, although these logs are very hard to understand, I could have easily missed it. Is there anything in particular I should look for? Thank you for help.

cpetepf gravatar imagecpetepf ( 2018-04-08 05:33:47 -0500 )edit

You can try disabling wakeups from mouse movements and see if that does the trick.

Aeyoun gravatar imageAeyoun ( 2018-04-08 09:44:27 -0500 )edit

Just turn your monitor off before you go to sleep and turn it back on when you wake up.

To me it's not surprise that a monitor turns on when connected to a running machine and all the potential Gnome notifications (email, calendar, updates,...)

florian gravatar imageflorian ( 2018-04-08 16:18:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-04-06 04:16:28 -0500

Seen: 89 times

Last updated: Apr 08