Sound device doesn't work on Intel compute stick above 26

asked 2018-04-09 14:34:03 +0000

Dn gravatar image

updated 2018-04-17 00:47:17 +0000

I'm using Fedora on Intel compute stick STK1AW32SC, and it worked well to version 26. But, sound device doesn't work with Fedora above 26. I tried everything I could like disabling Pulseaudio, and activating ALSA, and I also tried this.

aplay -l

It showed that it recognised sound device.

I think that it is because of kernel. Even on Fedora 26, sound device doesn't work with kernel version above 4.13. It only works properly with kernel version below 13. I checked it works well with kernel version 4.11, I don't know it works with kernel version 4.12.

I don't know much about programming, so I don't know it is caused by kernel.

Additional Information

I tried Linuxium's instructions after I saw that Linuxium posted an article related to sound device problem on Intel compute stick STK1AW32C. It seems to work to the step, checking what sound device works. aplay -l shows that hw:0,2 works. aplay -D hw:0,2 "sound" played sound. So, I applied Linuxium's script, but I failed to run Pulseaudio after applying that. After that, I tried to use ALSA, but it didn't work.

This is my /etc/pulse/default.pa

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif
### Linuxium fix for HDMI audio on Intel Compute Stick products STK1A32SC and STK1AW32SC
unload-module module-alsa-card
load-module module-alsa-sink device=hw:0,2
### Linuxium fix for HDMI audio on Intel Compute Stick products STK1A32SC and STK1AW32SC
unload-module module-alsa-card
load-module module-alsa-sink device=hw:0,2

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail ...
(more)
edit retag flag offensive close merge delete

Comments

1

Check if you can reuse this solution: http://linuxiumcomau.blogspot.com/201...

ozeszty ( 2018-04-13 17:49:53 +0000 )edit

I tried those instructions, but they didn't work on Fedora. I need to wait until Fedora developers fix this problem before Fedora 29 release. If this problem isn't fixed when Fedora 29 is released, I use Ubuntu or distributions based on Ubuntu.

Dn ( 2018-04-15 10:43:39 +0000 )edit

Which part didn't work? Have you found the working device and updated PulseAudio config accordingly?

ozeszty ( 2018-04-15 22:22:49 +0000 )edit

I edited this, and added some information.

Dn ( 2018-04-16 10:13:53 +0000 )edit

There's also newer workaround linked in comments: http://linuxiumcomau.blogspot.com/201... Post your /etc/pulse/default.pa if it still doesn't work.

Anyway it's definitely an issue that should be reported on bugzilla for upstream fix.

ozeszty ( 2018-04-16 11:28:15 +0000 )edit