Ask Your Question
1

How to disable lid closed sensor - tablet mode

asked 2018-04-09 13:25:13 -0500

k1monfared gravatar image

updated 2018-04-14 21:31:47 -0500

Background: I use a thinkpad X220t, and I often need to put it in tablet mode for writing. For the past year or so, every time I turn the monitor and put it in tablet mode, the screen turns off, just the screen. It depends on the angle between the monitor and keyboard, and weirdly, the threshold has increased over time. I have tried to tweak the settings of close-lid but it seems like the only options that I have change the settings for when the lid is closed normally, and not in the tablet mode (i.e. when the monitor is turned).

Question: How can I turn off the close-lid sensor completely (including the tablet mode) so that fedora doesn't realise the lid is being closed?

I'm hoping to use this temporarily until I find a fix (which now I'm guessing that it could be a hardware problem).

UPDATE: I've changed the settings in /etc/systemd/logind.conf to

HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore

and it didn't help.

UPDATE 2: When I run sudo acpitool -w, this is the output I get

   Device   S-state   Status   Sysfs node
  ---------------------------------------
  1. LID      S3    *enabled   platform:PNP0C0D:00
  2. SLPB     S3    *enabled   platform:PNP0C0E:0

Which then I can enable or disable either of them. I did disable both and the screen turns off with any combination of on and off for the 2 devices listed above.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-04-10 08:18:51 -0500

ozeszty gravatar image

Look through dconf-editor and gnome-tweak-tool, maybe you'll find something useful there.

Here are docs for module that controls lid sensor: https://www.kernel.org/doc/Documentat...

Maybe acpitool -W x (get x from devices acpitool -w lists) can disable this sensor, though it's intended for controlling suspend/wake up.

If it has never worked as intended or it regressed, report a bug

edit flag offensive delete link more

Comments

Thanks. I did try that, and disabling the devices did not help. Could that be a hardware problem?

k1monfared gravatar imagek1monfared ( 2018-04-14 21:35:02 -0500 )edit

Also, the link you provided says: 0x5009 Tablet swivel: switched to tablet mode and 0x500A Tablet swivel: switched to normal mode but these events do not propagate to the driver. What can I actually do with this info? I tried to use xmodmap to read what keys are being pressed when I rotate the monitor and put it in tablet mode, but there's no output.

k1monfared gravatar imagek1monfared ( 2018-04-14 21:36:51 -0500 )edit

Run evtest as root, there should be lid switch and maybe accelerometer or gyroscope, maybe that way you'll see which device is taking when your screen goes dark.

If it has gotten worse with time, it might also be display cable issue.

ozeszty gravatar imageozeszty ( 2018-04-16 15:13:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-09 13:25:13 -0500

Seen: 88 times

Last updated: Apr 14