Ask Your Question
0

Fedora 27 black screen at boot after grub

asked 2018-04-14 16:38:16 -0500

rickyjumb gravatar image

updated 2018-04-15 04:40:28 -0500

I'm having problems getting the system to boot. This is my first time with Fedora. I installed it and everything went ok, the system correctly picked up the other os already installed and when I rebooted for the first time after finishing the installation, everything went fine. The problem presented itself after updating through the package installer (the same thing as the Ubuntu software center, still have to learn the name of this one). After updating and installing a new kernel version, the system rebooted itself. My problem is that after grub, with the new kernel I just get a black screen, system unresponsive. The old one works just fine. The new kernel version that got installed is 4.15.15-300.fc27.x8664. The working one is 4.13.9-300.fc27.x8664. I tried both with nouveau and with Nvidia drivers from rmpfusion. I also tried the nuclear option and just reinstalled Fedora and this time I updated the system through yum in the terminal doing "yum check-update" and "yum update" both as root. This didn't fix the problem. I tried to get a command line with ctrl + alt + F2 but nothing. My pc has an sli of two Nvidia cards and Fedora is installed in uefi mode. Does anyone have an idea on how to fix this?

edit retag flag offensive close merge delete

Comments

Have you installed Nvidia proprietary driver or is it using nouveau?

fcomida gravatar imagefcomida ( 2018-04-14 19:44:43 -0500 )edit

It's using nouveau. After reinstalling for the second time I also tried the Nvidia drivers from rmpfusion

rickyjumb gravatar imagerickyjumb ( 2018-04-15 04:28:11 -0500 )edit
MettaCrawler gravatar imageMettaCrawler ( 2018-04-15 05:54:23 -0500 )edit

Nope, my system is completely unresponsive and just hangs up with a black screen with nouveau drivers too. Also, when i tried the nvidia drivers, the working kernel booted up just fine and the graphics card was correcly detected. Also, my integrated graphics card is disabled

rickyjumb gravatar imagerickyjumb ( 2018-04-15 06:39:02 -0500 )edit

put nomodeset=0 on linux command line at startup. should give a low rez gui, then install the nvidia driver of your choice. I prefer proprietary, with dkms and 32bit compatibility, so that wine works for older windows apps I still run. Fedora 27 with GeForce GTX 970 been using dkms since I installed fedora 24.

steveebey73742 gravatar imagesteveebey73742 ( 2018-04-15 08:00:46 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-04-15 10:02:22 -0500

rickyjumb gravatar image

Thank you to everyone that tried to help, I solved the problem by removing nouveau and installing the proprietary Nvidia drivers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-14 16:36:05 -0500

Seen: 912 times

Last updated: Apr 15