English
Ask Your Question
2

Broadcam Wifi Not Working in Fedora 28 beta

asked 2018-04-15 13:42:04 +0000

SKG gravatar image

I recently moved on to Fedora 28 Beta from Fedora 26. I am not able to get the Wifi up and working. Here are more details,

The output of lspci | grep -i broadcom is 08:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)

sudo modprobe wl gives output modprobe: FATAL: Module wl not found in directory /lib/modules/4.16.0-0.rc4.git0.1.fc28.x86_64

The directory /lib/modules gives contains two directories named 4.16.0-0.rc4.git0.1.fc28.x86_64 & 4.16.1-300.fc28.x86_64

I already installed kernel-devel, kernel-headers, broadcom-wl-6.30.223.271-3.fc27.noarch.rpm (downloaded from https://rpmfind.net/linux/rpm2html/se... and installed using rpm -ivh). For me, It seems that Broadcom drivers are not available for fedora 28 yet. If that's true then, how can i use wifi now

Please help to resolve this problem, I have tried many things, but could not figure out what's wrong.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-04-16 03:01:03 +0000

Well; if broadcom from rpmfusion doesn't work for you. I can recommend to install Unitedrpms...

1) dnf -y install broadcom-wl-dkms

2) reboot

Note:

If you will to use the broadcom from unitedrpms; then you need remove broadcom-wl from rpmfusion; and install broadcom-wl-dkms

edit flag offensive delete link more
0

answered 2018-04-15 21:51:34 +0000

ozeszty gravatar image

Use RPMFusion.org repositiores, F28 is already supported there. Plug in etherenet cable and run:

su
dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm -y
dnf install broadcom-wl
modprobe wl
edit flag offensive delete link more

Comments

If you will to use the broadcom from unitedrpms; then you need remove broadcom-wl from rpmfusion; and install broadcom-wl-dkms

1) dnf -y remove broadcom-wl && dnf -y install broadcom-wl-dkms

2) reboot
davidva ( 2018-04-16 02:56:11 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2018-04-15 13:42:04 +0000

Seen: 59 times

Last updated: Apr 16