Ask Your Question
3

help with jedi-vim

asked 2018-04-30 12:41:49 -0500

thirtyminutestosignup gravatar image

Hi, I want use jedi-vim for autocompletion in vim. I have installed jedi vim with: dnf install vim-jedi now, if I open a python file I have the following error:

 Please install Jedi if you want to use jedi-vim.     
Premi INVIO o un comando per proseguire

if I open /usr/share/doc/vim-jedi/README, I read:

Documentation is available in your vim: ``:help jedi-vim``. You can also look                             
it up `on github <http://github.com/davidhalter/jedi-vim/blob/master/doc/jedi-vim.txt>`_.

if I type :help jedi-vim in vim I have got:

149: Spiacente, nessun aiuto per jedi-vim

that means: I am sorry I have not any jedi-vim help.

Anyone can help me ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-30 13:51:21 -0500

florian gravatar image

That means you have to install Jedi before you can use the jedi-vim plugin (vim-jedi).

As of now, it is not in Fedora's repositories yet, see here for Installation instructions: https://jedi.readthedocs.io/en/latest...

As it says in the message, you can find the help file here: https://github.com/davidhalter/jedi-v... .It also talk about the Requirements of the plugin.

edit flag offensive delete link more

Comments

I think that jedi is installed. Its name should be python2-jedi.

# rpm -qa|grep -i jedi                                             
vim-jedi-0.8.0-3.fc27.noarch                         
python2-jedi-0.10.2-2.fc27.noarch
thirtyminutestosignup gravatar imagethirtyminutestosignup ( 2018-04-30 13:58:51 -0500 )edit
1

So, it actually is in the repos. Install python3-jedi as well. Interestingly, python3-jedi shows no build in any repos (same as python2-jedi. Did you get python2-jedi by installing pyhton-jedi(https://apps.fedoraproject.org/packag...

You can also try updating to the recent build from updates-testing

florian gravatar imageflorian ( 2018-04-30 14:02:41 -0500 )edit
1

ok, Solved. I have to add the following setting to .vimrc:

python3 import jedi

You can use python2 or python3... I have installed python3-jedi because in .vimrc I have the powerline plugin that run on python3 Thank you.

thirtyminutestosignup gravatar imagethirtyminutestosignup ( 2018-04-30 14:10:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-04-30 12:41:49 -0500

Seen: 165 times

Last updated: Apr 30 '18