Ask Your Question
1

Terminator vs ctrl shift e gnome key: how to disable gnome key intervention?

asked 2018-05-06 04:47:06 -0500

Guus gravatar image

updated 2018-05-08 04:55:28 -0500

I just upgraded from Fedora 27 to Fedora 28. Since then my terminator terminal emulation will no longer receive the Ctrl-shift-E key. In stead I get an "ibus emoji typing" window (see . I suspect this is necessary for languages with non-english tokens. I only use US-international, US with euro and straight english. I really do not need the emoji typing. I suspect gnome might block other keys as well, like ctrl-shift-W and others.

How can I make sure that Terminator receives keys I want it to receive including keys that gnome "wants"?

EDIT1. Neither in settings nor in tweaks could I find the shortcut ctrl-shift-E. I could find it in terminator, but it points to a vertical split screen (which is what I want). So apparantly the key never reaches Terminator, but gets stopped before. I really would expect this to be part of settings (keyboard/shortcuts).

EDIT2. Using top / atop / htop I could not find the application responsible which makes it impossible to find the package that the application is part of. The "ibus emoji typing" window might be part of the gnome shell or such. If anyone knows how to find out to which binary an open window belongs, I am all ears.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-11 08:42:34 -0500

cardoso gravatar image

type ibus-setup and navigate to Emoji tab and disable or change the shortcut!

edit flag offensive delete link more

Comments

guffert gravatar imageguffert ( 2018-05-13 06:11:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-05-06 04:47:06 -0500

Seen: 275 times

Last updated: May 08