Ask Your Question
0

Fedora 28: Screen Keyboard opens at startup

asked 2018-05-06 15:10:24 -0600

meauw1 gravatar image

updated 2018-05-07 00:34:54 -0600

Recently I switched from Fedora 27 to 28 and wanted to try another Desktop environment. So I found out that LXQT is just decent on some old notebook devices. So we're talking here about a freshly installed Fedora 28 from the LQqt live iso media. Everything's fine now apart from one annoying issue:

Upon every boot it shows up the onscreen keyboard in the login manager. How can I prevent this onscreen keyboard from filling up the whole screen every time on boot? I actually can't even imagine any situation I would need it anyways. Is there any way to disable it at startup or to just completely remove it?

Thank you!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-08-30 15:07:15 -0600

On my LXQt spin, this is handled by the sddm-greeter which reads in the sddm configurations.

To work around this, I added a directory /etc/sddm.conf.d/ and put in a file called disable-virtualkeyboard.conf ( /etc/sddm.conf.d/disable-virtualkeyboard.conf ) and added the line "InputMethod=" which disabled this.

It seems to default to "qtvirtualkeyboard" behavior which shows the on-screen keyboard as outlined in the man page for sddm.conf.

edit flag offensive delete link more
0

answered 2018-05-07 15:32:12 -0600

andyvsr gravatar image

Hi, I have the same issue, but didnt find a config to disable it. So i simply removed :

#dnf erase qt5-qtvirtualkeyboard.x86_64

Is the logout working for you ? when i simply click Leave -> Logout the system hangs (i use a vmware machine). with fedora 28 lxde i have no problem.

Thanks.

edit flag offensive delete link more

Comments

Hey there and thanks for your suggestion. I also made a step like this. Just switched to LightDM which also works fine. Just thinking, you think it's worth submitting a bug report to the fedora trackers on this?

Getting back to your question: No, logout works fine here (but it's a bare metal machine). So this seems to be related to your config/vm.

meauw1 gravatar imagemeauw1 ( 2018-05-14 01:56:14 -0600 )edit
0

answered 2018-05-06 23:13:36 -0600

Gaurav29 gravatar image

Hey there, I haven't used LXQT, but in in Gnome there is a option to turn on and off the screen keyboard option at the login manager, you can find it near the upper right hand corner. Hope this works.

edit flag offensive delete link more

Comments

Hey and thank you! Sadly, after trying out the only two buttons at the upper pane of the login manager I have shutdown and rebooted but nope, that's the only thing these buttons do (even though they do their job very well without asking again if you'd really like to reboot - which is odd, if every other button asks for verification. But that's probably something to hand over to qa). So concluding: No, unluckily there's no button to turn it off. Also if you'd mind answering: I haven't found out how to pin down, which display/login manager this actually is. Which is the default one on the LXQT?

meauw1 gravatar imagemeauw1 ( 2018-05-07 00:34:27 -0600 )edit

Like I said, I don't know about LXQT, but in gnome when u enter username root then when u press next, to enter the password there is a little gear icon click on it, maybe this is what you're looking for.

Gaurav29 gravatar imageGaurav29 ( 2018-05-07 03:26:37 -0600 )edit

nope, I absolutely do not know how the LXQT spin standard DM is called, but it definitely does not offer any options apart from logging in, restarting and shutting down. At least if haven't found one other button/option. I just resolved the issue by installing lightDM and making it the default DM, which is a solution, but not the one intended at first place.

meauw1 gravatar imagemeauw1 ( 2018-05-14 09:42:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-06 15:10:24 -0600

Seen: 554 times

Last updated: May 07