Ask Your Question
1

Powersupply failed during upgrade

asked 2018-05-08 09:21:45 -0500

pnelsonsr gravatar image

Did standard dnf upgrade and after rebooting and installing phase the systems powersupply failed. After fixing the powersupply the system booted to 27. So I tried running the commands again but that didn't cause a reboot-install. So I did a

dnf distro-sync --disableplugin=protected_packages --releasever=28

which mostly worked. But the system kind of sees itself as 27 as there are a number of packages that didn't update:

ghostscript-fonts.noarch
libyubikey.x86_64 lsscsi.x86_64
lua-filesystem.x86_64 mc.x86_64
mdadm.x86_64 ocaml-srpm-macros.noarch
openblas-srpm-macros.noarch
php-password-compat.noarch
zfs-fuse.x86_64

And I can not get them to update to version 28.

Anyone have a idea how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-08 10:09:42 -0500

fcomida gravatar image

That's perfectly normal, a mass rebuild hasn't yet occurred for Fedora 28, some packages are still from f27.

edit flag offensive delete link more

Comments

2

For some packages the version you had in fc27 will be the same version available in fc28. These packages are not updated. Sometime the fc27 version is actually newer than the fc28 version.

Some package maintainers don't even update the version suffix, so when these packages are rebuild in fc28 they will still have the old version suffix. Try run

dnf list NearTree

and see some real old version suffix.

villykruse gravatar imagevillykruse ( 2018-05-08 16:03:09 -0500 )edit

OK well, it does appear to be working!

pnelsonsr gravatar imagepnelsonsr ( 2018-05-14 09:23:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-08 09:21:45 -0500

Seen: 42 times

Last updated: May 08