Ask Your Question
1

ISOFS: Unable to identify CD-ROM format.

asked 2018-05-13 12:03:08 -0500

zaynab gravatar image

updated 2018-05-17 15:47:53 -0500

ssieb gravatar image

please Help :(

I have this error while I'm trying mount iso file

[zaynabo@localhost LinuxMatlab]$ sudo mount -t iso9660 -o loop \[Downloader.ga\]R2017b_glnxa64_dvd1.iso /mnt/cdrom/
[sudo] password for zaynabo: 
mount: wrong fs type, bad option, bad superblock on /dev/loop1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so.

thanks in advance the output of "dmesg | tail " :

[ 4526.711557] ISOFS: Unable to identify CD-ROM format.
edit retag flag offensive close merge delete

Comments

2

Run isoinfo and/or isovfy from package cdrtools on the iso image.

fcomida gravatar imagefcomida ( 2018-05-13 16:27:20 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-05-18 13:20:32 -0500

zaynab gravatar image

updated 2018-05-18 13:28:06 -0500

@ssieb

I get the same error without -t parameter

zaynab@zaynab-PC:~/Documents/LinuxMatlab$ sudo mount -o loop [Downloader.ga]R2017bglnxa64dvd1.iso /mnt/cdrom/ mount: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so.

here is the output of " file [Downloader.ga]R2017bglnxa64dvd1.iso"

[Downloader.ga]R2017bglnxa64dvd1.iso: ISO-8859 text, with very long lines, with no line terminators

isoinfo and isovfy doesn't work also :( !

edit flag offensive delete link more

Comments

Out of curiosity, what's the file size? It seems to be a text file encoded in ISO-8859, which covers most western european languages (pre Unicode era). Anyway you better download it again.

fcomida gravatar imagefcomida ( 2018-05-18 17:09:24 -0500 )edit

it's 7.1 GB :( OK I'm going to download it again thanks

zaynab gravatar imagezaynab ( 2018-05-19 18:41:55 -0500 )edit
0

answered 2018-05-17 15:51:26 -0500

ssieb gravatar image

You don't need the -t parameter, try without it. What is the output of file \[Downloader.ga\]R2017b_glnxa64_dvd1.iso? If that identifies it as an ISO file, then try the other commands that @fcomida suggested.

edit flag offensive delete link more

Comments

You could probably read your file with: less R2017bglnxa64dvd1.iso (Esc to exit reading). which does not seems normal, and suggest you need to redownload MatLab 2017 (seems to have a problem with 2018 version and Fedora 28: need to be run with -nodesktop option).

PaulD gravatar imagePaulD ( 2018-05-18 14:57:29 -0500 )edit

I will re-download it again, thanks @PauID

zaynab gravatar imagezaynab ( 2018-05-19 21:00:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-13 12:03:08 -0500

Seen: 44 times

Last updated: May 18