Ask Your Question
1

Upgrading 27 to 28 problems

asked 2018-05-13 15:51:17 -0500

Blaine gravatar image

I'm following the upgrade guide.

I did:

sudo dnf upgrade --refresh
sudo dnf system-upgrade download --releasever=28

I get

Error: Transaction check error:
file /usr/include/sasl/md5global.h conflicts between attempted installs of cyrus-sasl-devel-2.1.27-0.1rc7.fc28.i686 and cyrus-sasl-devel-2.1.27-0.1rc7.fc28.x86_64

I checked to see what dnf remove cyrus-sasl-devel would do and it said sudo is using it, so I left it alone.

How do troubleshoot this? (please and thank you)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-05-13 17:11:23 -0500

villykruse gravatar image

Try with --noautoremove

dnf remove  --noautoremove cyrus-sasl-devel

By default, when removing a package dnf will also remove packages which has been required by this packages, and which are no longer required any more.

edit flag offensive delete link more

Comments

That worked great. Thanks.

Blaine gravatar imageBlaine ( 2018-05-13 21:37:26 -0500 )edit
0

answered 2018-05-16 06:55:45 -0500

rhandwor52 gravatar image

I had to add --allowerasing sudo dnf system-upgrade download --releasever=28 --allowerasing

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-13 15:51:17 -0500

Seen: 144 times

Last updated: May 16