Ask Your Question

SELinux Issue

asked 2018-05-14 22:43:36 -0600

Rspigler gravatar image

SELinux seems to blocking tor from accessing its own files.

localhost.localdomain tor [20336]: [notice] Read configuration file "/usr/share/tor/defaults-torrc". localhost.localdomain tor [20336]: [notice] Read configuration file "/etc/tor/torrc".

localhost.localdomain audit [20336]: AVC avc: denied { dacreadsearch } for pid=20336 comm="tor" capability=2 scontext=systemu:systemr:tort:s0 tcontext=systemu:systemrtort:s0 tclass=capability permissive=0

localhost.localdomain audit [20336]: AVC avc: denied {dacoverride } for pid=20336 comm="tor" capability=1 scontext=systemu:systemr:tort:s0 tcontext=systemu:systemr:tort:s0 tcpmtext=systemu:systemr:tort:s0 tclass=capability permissive=0

localhost.localdomain tor[20336] [warn] Directory /var/lib/tor/bitcoin-service/ cannot be read: Permission denied

localhost.localdomain tor[20336] [warn] Failed to parse/validate config: Failed to configure rendezvous options. See logs for details.

localhost.localdomain tor[20336] [err] Reading config failed --see warnings above.

localhost.localdomain systemd[1]: tor.service: Control process exited, code=exited status=1

localhost.localdomain systemd[1]: tor.service: Failed with result 'exit-code'.

localhost.localdomain systemd[1]: Failed to start Anonymizing overlay network for TCP.

Right now, I've been able to disable SELinux to run tor, but there's got to be a better way than just completely disabling it. But that's all I could come up with.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-05-22 06:13:35 -0600

sixpack13 gravatar image

install and try to run setroubleshoot

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2018-05-14 22:43:36 -0600

Seen: 96 times

Last updated: May 22 '18