Ask Your Question
0

[Fedora 28] Eclipse crash at startup

asked 2018-05-26 10:17:34 -0500

berhthun gravatar image

Hello,

Fedora 28 user, I installed Eclipse (version: 1:4.7.3a-4.fc28) by using gnome software.

I start Eclipse, select a blank folder as workspace and click on Launch. After that an error message is displayed :

An error has occurred. See the log file

workspace/.metadata/.log

I went to the log file but did not manage to determine an action to prevent this error.

What should I do ? Thank you in advance for your help.

The content of the log file :

!SESSION 2018-05-26 16:38:06.759 -----------------------------------------------
eclipse.buildId=4.7.3.v20180409-1128
java.version=1.8.0_171
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=fr_FR
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.recommenders.apidocs.rcp 4 0 2018-05-26 16:38:10.525
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.recommenders.apidocs.rcp [1430]
  Unresolved requirement: Require-Bundle: org.eclipse.recommenders.injection; bundle-version="[2.5.1,2.5.2)"
    -> Bundle-SymbolicName: org.eclipse.recommenders.injection; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
       org.eclipse.recommenders.injection [1441]
         Unresolved requirement: Require-Bundle: com.google.inject; visibility:="reexport"
           -> Bundle-SymbolicName: com.google.inject; bundle-version="4.1.0"
              com.google.inject [200]
                Unresolved requirement: Import-Package: com.google.common.base; version="[18.0.0,19.0.0)"
  Unresolved requirement: Require-Bundle: org.eclipse.recommenders.models.rcp; bundle-version="[2.5.1,2.5.2)"
    -> Bundle-SymbolicName: org.eclipse.recommenders.models.rcp; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
       org.eclipse.recommenders.models.rcp [1447]
         Unresolved requirement: Require-Bundle: org.eclipse.recommenders.coordinates.rcp; bundle-version="[2.5.1,2.5.2)"
           -> Bundle-SymbolicName: org.eclipse.recommenders.coordinates.rcp; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
              org.eclipse.recommenders.coordinates.rcp [1438]
                Unresolved requirement: Require-Bundle: org.eclipse.recommenders.injection; bundle-version="[2.5.1,2.5.2)"
                  -> Bundle-SymbolicName: org.eclipse.recommenders.injection; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
                Unresolved requirement: Require-Bundle: org.eclipse.recommenders.rcp; bundle-version="[2.5.1,2.5.2)"
                  -> Bundle-SymbolicName: org.eclipse.recommenders.rcp; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
                     org.eclipse.recommenders.rcp [1456]
                       Unresolved requirement: Require-Bundle: org.eclipse.recommenders.injection; bundle-version="[2.5.1,2.5.2)"
                         -> Bundle-SymbolicName: org.eclipse.recommenders.injection; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.recommenders.rcp; bundle-version="[2.5.1,2.5.2)"
           -> Bundle-SymbolicName: org.eclipse.recommenders.rcp; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.recommenders.injection; bundle-version="[2.5.1,2.5.2)"
           -> Bundle-SymbolicName: org.eclipse.recommenders.injection; bundle-version="2.5.1.v20180320-1641"; singleton:="true"
  Unresolved requirement: Require-Bundle: org.eclipse.recommenders.rcp; bundle-version="[2.5.1,2.5.2)"
    -> Bundle-SymbolicName: org.eclipse.recommenders.rcp; bundle-version="2.5.1.v20180320-1641"; singleton:="true"

    at org.eclipse.osgi.container.Module.start(Module.java:444)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1634)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1613)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java ...
(mas)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-28 03:20:58 -0500

berhthun gravatar image

By looking at the wiki, it appears there where differences between the system bundles and the user bundles.

Following these steps resolved the problem :

  1. Uninstalling Eclipse
  2. Deleting ~/.eclipse
  3. Installing Eclipse
edit flag offensive delete link more

Comments

Just deleting ~/.eclipse ought to be enough.

genodeftest gravatar imagegenodeftest ( 2018-05-31 06:10:28 -0500 )edit

Unfortunately, it's not.

I'm hitting this same issue. I've deleted ~/.eclipse and the workspace and restarted Eclipse and get the same problem over and over again.

mcpierce gravatar imagemcpierce ( 2018-08-15 18:51:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-26 10:17:34 -0500

Seen: 209 times

Last updated: May 26