Ask Your Question
0

Gray Screen after logging in

asked 2018-06-02 01:14:00 -0600

grumpymaestro gravatar image

I recently installed Fedora 27 Workstation Edition alongside Windows 10, and everything was fine and dandy. The only issue is that Fedora was the default OS in Grub2, but I use windows 10 much more often.

I looked into it, and after trying and failing to achieve it by modifying /etc/default/grub, I found out I had to modify /boot/efi/EFI/fedora/grub.cfg instead, following this guide.

But then I made the mistake of also installing grub-customizer, as well, without restarting. It installed and ran perfectly, and I was able to move Win10 to the top of the menu. After this I restart, and lo and behold win10 was at the top, but because I had set default boot to be entry 4 (the fifth from the top) recovery was now the default boot. Whoops.

So I go to boot into fedora, and it takes a bit to take me to the login menu, must be a hiccup from the settings I just changed. I log in as usual, and encounter a grey screen. Oh. So I try different Kernels, nothing.

I've been looking for solutions, but they all mention different causes, and nothing has worked. Luckily, I've still got win10 working, but until I can fix Fedora, I'm out of Linux.

Is there a way to fix this that doesn't require me to do a fresh install of Fedora?

Any and all help is appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-02 03:32:34 -0600

villykruse gravatar image

If you modify /etc/default/grub you need to run grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg for the changes to take effect. I expect that running grub2-mkconfig will undo any changes made by grub-customizer

For documentation run pinfo grub2 or info grub2 (you may need to install the pinfo or info package).

Then select "Configuration" --> "Simple configuration".

edit flag offensive delete link more

Comments

I'm pretty sure I ran grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg. Hoping that grub2-mkconfig will fix it.

<edit> I ran grub2-mkconfig, and while it did reset the default boot to the 0th entry, the 0th entry is still windows, and none of the kernels will load. I'll try running it with the extra terms to see if it helps, as I might have ran just grub2-mlconfig. Will provide updates.

grumpymaestro gravatar imagegrumpymaestro ( 2018-06-02 14:55:21 -0600 )edit

I ran grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg and the result was:

/usr/bin/grub2-mkconfig line 248: /boot/efi/EFI/fedora/grub.cfg.new : No such file or directory exists

Going to explore pinfo and info for any possible solutions while I await responses.

grumpymaestro gravatar imagegrumpymaestro ( 2018-06-02 15:20:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-02 01:14:00 -0600

Seen: 118 times

Last updated: Jun 02