Ask Your Question
2

Grey Screen after logging in (Grub2 problems)

asked 2018-06-05 16:30:12 -0500

grumpymaestro gravatar image

I recently installed Fedora 27 Workstation Edition alongside Windows 10, and everything was fine and dandy. The only issue is that Fedora was the default OS in Grub2 as entry 0, but I use windows 10, entry 4, much more often.

I looked into it, and after trying and failing to achieve it by modifying /etc/default/grub, I found out I had to modify /boot/efi/EFI/fedora/grub.cfg instead, following this guide.

But then I made the mistake of also installing grub-customizer, as well, without restarting. It installed and ran perfectly, and I was able to move Win10 to the top of the menu. After this I restart, and lo and behold win10 was at the top, but because I had set default boot to be entry 4 (the fifth from the top) recovery was now the default boot. Whoops.

So I go to boot into fedora, and it takes a bit to take me to the login menu, must be a hiccup from the settings I just changed. I log in as usual, and encounter a grey screen. Oh. So I try the next 3 Kernels, nothing.

I've already asked this question but it seems to have gone mostly ignored and I still can't log into Fedora.

Thanks to advice from the previous question, I ran grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg and the result was:

/usr/bin/grub2-mkconfig line 248: /boot/efi/EFI/fedora/grub.cfg.new : No such file or directory exists

I'm wondering if I could try to look up the default grub.cfg file and create a new one using VIM, or something.

Help?

edit retag flag offensive close merge delete

Comments

There may be several things happening here. I will only comment on your last error. Before running grub2-mkconfig, type in the following command beforehand:cd /boot/efi/EFI/fedora just for giggles. I suspect you have an EFI partition, you are using grub2, AND fedora doesn't mount that partition once the kernel is up and running. Changing the grub.cfg file (using "-o output to a file here") won't work unless the directory structure is in place (i.e. mounted as part of the filesystem and writeable). If you can't "cd" to that directory, grub2-mkconfig can't write a file to it.

lovepump gravatar imagelovepump ( 2018-06-11 18:20:57 -0500 )edit

Sounds like more than one thing is going on. Can you post the URLs from:

fpaste /etc/fstab
fpaste /etc/default/grub
df -h | grep fpaste

To have some idea what might be going on with the gray screen, we're gonna need to see the journal. If you have another computer, you can use scp to copy it to that computer. Or you'll need to plug in a USB stick, mount it and copy the journal over. e.g.

sudo journalctl -b -o short-monotonic > journal.log
scp journal.log <destination>
cmurf gravatar imagecmurf ( 2018-06-11 18:48:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-11 18:57:57 -0500

cmurf gravatar image

To fix the GRUB issue, reinstall GRUB and SHIM:

sudo dnf reinstall shim grub2-efi
sudo grub2-mkconfig /boot/efi/EFI/fedora/grub.cfg
edit flag offensive delete link more

Comments

I agree with cmurf. However, another thing that might "yield answers" to your "grey screen" is pressing escape before or while it happens. I am not overly familiar with "plymouth", which i understand is trying to be a graphical display of the kernel boot messages (dmesg) as they happen. If there is any "trouble" regarding "legacy video stuff", trying to see it in a simpler fashion may also help.

lovepump gravatar imagelovepump ( 2018-06-11 20:08:41 -0500 )edit

Also, in general whenever I have encountered "obnoxiously long boot times" almost always they have been attributable to having "automatic NFS mounts" that are unreachable during boot.

lovepump gravatar imagelovepump ( 2018-06-11 20:14:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-05 16:30:12 -0500

Seen: 52 times

Last updated: Jun 11