Disable screen blanking (screensaver) in Mate (Fedora 29)

asked 2018-06-09 07:12:02 -0500

basic6 gravatar image

updated 2018-06-09 08:18:03 -0500

How can the screensaver and/or screen blanking be disabled in MATE?

It should be easy but apparently it's not. In the power management preferences (mate-power-preferences), "Put display to sleep when inactive for" is set to "Disabled". In the screensaver settings (mate-screensaver-preferences), "Activate screensaver when computer is idle" is not checked.

$ gsettings get org.mate.screensaver idle-activation-enabled 
false

Also, it seems like there are a few new(-ish) related bugs in Fedora 29. For example, the screen isn't locked anymore after reactivating the computer from standby mode, the battery icon is gone, unmount notifications are gone and so on (seen on several computers; these things worked before upgrading to F29).

OS version: Fedora 29, MATE Desktop 1.20

SELinux: In an old bug report, someone said that some power-related features may not work if SELinux is enabled. However, it doesn't seem like SELinux is the culprit here.

edit retag flag offensive close merge delete