Problem with RuneScape and libgl after installing Nvidia Drivers [closed]

asked 2018-06-13 17:16:51 -0500

djwolf gravatar image

updated 2018-06-24 06:56:02 -0500

hhlp gravatar image

I'm trying to run RuneScape after installing the NVidia drivers and this is the error text I receive:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

I have already tried installing the 32 bit version of the drivers and adding i915.modeset=1 to the grub command line. None of those have worked. This issue doesn't seem to be going away.

UPDATE-SOLVED: The issue was with the flatpak version of the NXT client. For whatever reason, it didn't play nicely with the Nvidia Drivers. I followed this guide to get the official client from the website to work on Fedora OS: https://www.reddit.com/r/runescape/comments/5lfsr1/nxtinstallationonfedora25/

EDIT: There's a couple of things wrong with that reddit tutorial. The "data.tar.gz" is actually a "data.tar.xz". Also where it says "ln -s /lib64/libGLEW.so.1.13", just replace that with the version that you have installed. Finally, webkitgtk isn't on the repos anymore for whatever reason, but you actually don't need it. It's ok to safely ignore this specific package.

EDIT-UNINSTALL PROCESS: I wanted to update this for completion. I've recently decided to grab a new hard drive and I now have a windows drive specifically for gaming. Unfortunately, because of the way the RS-Launcher was installed in this instance, uninstalling it isn't as easy as just removing a package. In order to uninstall this, you will need to find that data.tar.xz file used to create the data in the first place. Run this tar command on that file:

tar -tvf data.tar.xz

This will give you all of the contents that the application needed to run. You will need to go through and delete the files and directories associated with that tar file.

IMPORTANT: DO NOT DELETE THE DIRECTORIES UNLESS THEY HAVE "RUNESCAPE" IN THE NAME. DELETING ANOTHER DIRECTORY MAY CAUSE SYSTEM DAMAGE!

Once you're done removing all the files and directories associated with RS, you can safely delete the "data.tar.xz" file.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by hhlp
close date 2018-06-24 06:55:53.506121

Comments

if the nvidia drivers are proprietary, it may have overwritten the libgl that runescape installed, try reinstalling runescape.

steveebey73742 gravatar imagesteveebey73742 ( 2018-06-13 18:04:08 -0500 )edit

I installed Runescape after I installed the drivers. I also reinstalled RS multiple times after I received that error.

djwolf gravatar imagedjwolf ( 2018-06-13 19:01:17 -0500 )edit

what does glxinfo | grep render show you?

steveebey73742 gravatar imagesteveebey73742 ( 2018-06-13 19:54:25 -0500 )edit

[djwolf@localhost ~]$ glxinfo | grep render direct rendering: Yes OpenGL renderer string: GeForce GTX 660/PCIe/SSE2 GLARBconditionalrenderinverted, GLARBconservativedepth, GLKHRrobustness, GLKTXbufferregion, GLNVXconditionalrender, GLNVcomputeprogram5, GLNVconditionalrender, GLNVparameterbufferobject2, GLNVpathrendering, GLARBcomputevariablegroupsize, GLARBconditionalrenderinverted, GLKHRrobustness, GLKTXbufferregion, GLNVXconditionalrender, GLNVcomputeprogram5, GLNVconditionalrender, GLNVparameterbuff

djwolf gravatar imagedjwolf ( 2018-06-13 20:40:39 -0500 )edit