Ask Your Question
1

How can I install vpython module?

asked 2018-06-23 14:35:40 -0600

I have python3-pip installed on Fedora 28. I am trying to install the vpython module as follows:

pip3 install vpython

but it errors with No such file or directory reported by gcc. Here is the full output:

Collecting vpython
  Using cached https://files.pythonhosted.org/packages/df/d0/3f1737c5d6063fd028c7b3ee6f7e23bc764ad00fe50bb032abc83e8bd62c/vpython-7.4.4.tar.gz
Requirement already satisfied: jupyter in ./.local/lib/python3.6/site-packages (from vpython)
Requirement already satisfied: vpnotebook in ./.local/lib/python3.6/site-packages (from vpython)
Requirement already satisfied: numpy in ./.local/lib/python3.6/site-packages (from vpython)
Requirement already satisfied: autobahn in ./.local/lib/python3.6/site-packages (from vpython)
Requirement already satisfied: notebook in ./.local/lib/python3.6/site-packages (from jupyter->vpython)
Requirement already satisfied: jupyter-console in ./.local/lib/python3.6/site-packages (from jupyter->vpython)
Requirement already satisfied: nbconvert in ./.local/lib/python3.6/site-packages (from jupyter->vpython)
Requirement already satisfied: qtconsole in ./.local/lib/python3.6/site-packages (from jupyter->vpython)
Requirement already satisfied: ipykernel in ./.local/lib/python3.6/site-packages (from jupyter->vpython)
Requirement already satisfied: ipywidgets in ./.local/lib/python3.6/site-packages (from jupyter->vpython)
Requirement already satisfied: txaio>=2.10.0 in ./.local/lib/python3.6/site-packages (from autobahn->vpython)
Requirement already satisfied: six>=1.10.0 in /usr/lib/python3.6/site-packages (from autobahn->vpython)
Requirement already satisfied: pyzmq>=17 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: jinja2 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: ipython-genutils in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: traitlets>=4.2.1 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: nbformat in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: jupyter-core>=4.4.0 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: jupyter-client>=5.2.0 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: Send2Trash in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: terminado>=0.8.1 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: tornado>=4 in ./.local/lib/python3.6/site-packages (from notebook->jupyter->vpython)
Requirement already satisfied: prompt-toolkit<2.0.0,>=1.0.0 in ./.local/lib/python3.6/site-packages (from jupyter-console->jupyter->vpython)
Requirement already satisfied: ipython in ./.local/lib/python3.6/site-packages (from jupyter-console->jupyter->vpython)
Requirement already satisfied: pygments in ./.local/lib/python3.6/site-packages (from jupyter-console->jupyter->vpython)
Requirement already satisfied: testpath in ./.local/lib/python3.6/site-packages (from nbconvert->jupyter->vpython)
Requirement already satisfied: entrypoints>=0.2.2 in ./.local/lib/python3.6/site-packages (from nbconvert->jupyter->vpython)
Requirement already satisfied: mistune>=0.7.4 in ./.local/lib/python3.6/site-packages (from nbconvert->jupyter->vpython)
Requirement already satisfied: pandocfilters>=1.4.1 in ./.local/lib/python3.6/site-packages (from nbconvert->jupyter->vpython)
Requirement already satisfied: bleach in ./.local/lib/python3.6/site-packages (from nbconvert->jupyter->vpython)
Requirement already satisfied: widgetsnbextension~=3.2.0 in ./.local/lib/python3.6/site-packages (from ipywidgets->jupyter->vpython)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/lib64/python3.6/site-packages (from jinja2->notebook->jupyter->vpython)
Requirement already satisfied: decorator in /usr/lib/python3.6/site-packages (from traitlets>=4.2.1->notebook->jupyter->vpython)
Requirement already satisfied: jsonschema!=2.5.0 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-06-24 03:35:23 -0600

villykruse gravatar image

Install the missing package:

# dnf provides /usr/lib/rpm/redhat/redhat-hardened-cc1
Last metadata expiration check: 16:45:43 ago on Sat 23 Jun 2018 17:47:04 CEST.
redhat-rpm-config-108-1.fc28.noarch : Red Hat specific rpm configuration files
Repo        : @System
Matched from:
Filename    : /usr/lib/rpm/redhat/redhat-hardened-cc1

redhat-rpm-config-108-1.fc28.noarch : Red Hat specific rpm configuration files
Repo        : updates
Matched from:
Filename    : /usr/lib/rpm/redhat/redhat-hardened-cc1

redhat-rpm-config-106-1.fc28.noarch : Red Hat specific rpm configuration files
Repo        : fedora
Matched from:
Filename    : /usr/lib/rpm/redhat/redhat-hardened-cc1

So the missing packages is: redhat-rpm-config

dnf install redhat-rpm-config
edit flag offensive delete link more
0

answered 2018-06-24 06:39:10 -0600

updated 2018-06-24 08:01:53 -0600

Thanks villykruse. That got me one step closer. As it turns out, the package python-devel is also needed.

edit flag offensive delete link more

Comments

That would be python3-devel if you use pip3. python-devel is for the older python version 2.

villykruse gravatar imagevillykruse ( 2018-06-24 08:53:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-23 14:35:40 -0600

Seen: 47 times

Last updated: Jun 24