Ask Your Question
0

Troubleshooting setting up Wake-On-LAN

asked 2018-07-02 15:12:02 -0600

ricked gravatar image

Hi everyone !

First of all, I'd like to say thank you for reading me and/or answering me ! So thanks to you ! :) It's actually my first post, but i'm used to search a lot on AskFedora (which helped me a lot) ! So I will try to give a lot of information to my problem.

And here we go, time for some details on my problem. I'm trying to set up a computer with dualboot (Win10 / Fedora28) to Wake-On-Lan with Magic Packets. So I first look at my BIOS Setup to find an option to enable like "PCI Power Up" or "Magic Packet" options. But I can't find it. I read on another forum (I don't remember which one, because of several reboot due to testing ...), during online search that somehow, my BIOS is set to have this option forced to be enable, so no entry in BIOS Setup. The thing is, that when i modify boot option in BIOS Setup to Windows Boot Loader, WOL works. But I want to WOL on my grub. So here come some information on my BIOS and motherboard :

Informations get with "sudo dmidecode -s [string]" command :

[string]    :   [output]
bios-vendor :   American Megatrends Inc.
bios-version    :   F22
baseboard-manufacturer  :   Gigabyte Technology Co., Ltd.
baseboard-product-name  :   Z170-Gaming K3-CF

Then I assumed that the problem comes from Grub or Fedora. But I didn't find anything about grub configuration for WOL. So I assumed the problem was due Fedora configuration. I tried to enable WoL on my Network Card enp3s0 with ethtool command. After here every MAC Address show is not the real MAC Address of my Network Card, but i did all my test with the right one. So the false one is 00:11:22:33:44:55.

Here some information on my network card enp3s0 get with ifconfig enp3s0 :

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.24  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2a01:cb08:899b:ac00:3698:3f4e:2b6:52d6  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::211f:7fb4:5769:10a5  prefixlen 64  scopeid 0x20<link>
        ether 00:11:22:33:44:55  txqueuelen 1000  (Ethernet)
        RX packets 1393  bytes 149247 (145.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 332  bytes 35123 (34.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18

And here is the output of sudo ethtool -s enp3s0 wol g :

Cannot get current wake-on-lan settings: Operation not supported
  not setting wol

Then, I get these output with sudo ethtool enp3s0 :

Settings for enp3s0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-03 17:43:00 -0600

Glenn gravatar image

https://www.gigabyte.com/Support/FAQ/...

Does it support Wake on LAN (WOL)?

Yes, it supports. Wake on LAN function is enabled by default, just make sure to disable [Erp Support] option in BIOS setting.

edit flag offensive delete link more

Comments

ERP Support is disabled in my BIOS settings.

Sorry I didn't reply sooner, but I wasn't able to access the involved computer to verify my settings !

ricked gravatar imagericked ( 2018-07-27 13:06:13 -0600 )edit
0

answered 2018-07-03 03:47:08 -0600

Glenn gravatar image

I've used WOL successfully a few years ago to wake up 2 computers in another room. My notes include this: Check to see if '''wake-on-lan''' is enabled in BIOS Enabled "Power On By PCI (-E) Device" in BOIS

I read that you've dealt with wake-on-lan enabled in BIOS. Is there a Power On By PCI option that may need to be enabled?

edit flag offensive delete link more

Comments

Thank you for you answer :) But no, it seems to have no section for enable an option which looks like "Power On by PCI", there are only "Power on by Mouse", "Power on by Keyboard", "Power on by Password". The only settings in relation to PCI and Power is an option to enable ASPM (Active State Power Management) on PCI-E. I could be wrong, but I assume this is not relied to WoL options.

ricked gravatar imagericked ( 2018-07-03 07:53:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-02 12:24:50 -0600

Seen: 455 times

Last updated: Jul 03 '18