Ask Your Question
0

systemd.timesyncd.service fails to start

asked 2018-07-03 12:26:20 -0600

updated 2018-07-03 13:03:25 -0600

hhlp gravatar image

First post here and new to Fedora. I recently did a fresh install, I noticed that my network time was not synchronized.

First I checked timedatectl status, and I found that network time had not synchronized, so I set the set-ntp boolean to true. No change, next I checked /etc/systemd/timesyncd.conf uncommented the lines and added my time.google.com as my NTP server. After this, I tried to reboot systemd.timesyncd.service

systemctl status systemd-timesyncd.service 
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2018-07-03 16:48:10 HST; 13min ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 1111 (code=exited, status=217/USER)

ul 03 17:11:19 mypc.localdomainaudit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-timesyncd comm="systemd" exe="/usr/lib/systemd/syste>
Jul 03 17:11:19 mypc.localdomain audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-timesyncd comm="systemd" exe="/usr/lib/systemd/system>
Jul 03 17:11:19 mypc.localdomain systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
Jul 03 17:11:19 mypc.localdomain systemd[1]: systemd-timesyncd.service: Failed with result 'exit-code'.
Jul 03 17:11:19 mypc.localdomain systemd[1]: Failed to start Network Time Synchronization.
Unit systemd-timesyncd.service has failed
Defined-By: systemd
Unit systemd-timesyncd.service has failed.

The result is RESULT.

Jul 03 16:48:10 localhost.localdomain systemd[1093]: systemd-timesyncd.service: Failed to update dynamic user credentials: Permission denied Jul 03 16:48:10 localhost.localdomain systemd[1093]: systemd-timesyncd.service: Failed at step USER spawning /usr/lib/systemd/systemd-timesyncd: Permission denied

I checked the file permissions, root has rwx, not sure why permission would be denied, unless it's related to the selinux policy.

> -rwxr-xr-x. 1 root root system_u:object_r:init_exec_t:s0 44784 May 11 00:59 /usr/lib/systemd/systemd-timesyncd

Any suggestions on what to check next? Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-07-03 13:29:27 -0600

villykruse gravatar image

Two problems:

  • /var/lib/private has wrong permissions. Correct is:

    drwx------. 3 root root 4096 Jun 15 18:01 /var/lib/private/

  • SELinux is preventing creation of the requires files in /var/lib/private. Set SELinux to permissive and startsystemd.timesyncd.service. Then you use sealert to see what and how to fix the SELinux issues. You can then set SELinux back to enforcing.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-07-03 12:26:20 -0600

Seen: 264 times

Last updated: Jul 03