Can't get past the GDM login screen on Fedora 28

asked 2018-07-08 21:20:04 -0600

vikjes1969 gravatar image

Bear with me as I'm new to Fedora (but I've been running Arch for more than 10 years). After I successfully installed the nVidia proprietary driver, whenever I try to login using GDM, Fedora completely freezes. As a workaround I changed the default target to "multi-user.target" and I can do an old school "startx" and GNOME starts just fine. I suspect this has something to do with Wayland, but I assumed the installation of the nVidia driver would completely disable it. One thing I noticed is the lack of the "GNOME on Xorg" in the option button of the GDM screen which seems to suggest that GDM forces the start of GNOME using Wayland. I'd appreciate any tips or advice on this. Thanks.

edit retag flag offensive close merge delete

Comments

Can you switch to a tty and check whether gnome-session-xsession is installed? If not, please install it using dnf install gnome-session-xsession. It provides the /usr/share/xsessions/gnome-xorg.desktop file which gdm needs to display and start the "GNOME on Xorg" session. After that, please check whether the /usr/share/xsessions/gnome-xorg.desktop file exists and is readable.

You may want to try the open source nvidia driver because it has better compatibility with upstream and Fedora is often close to upstream in terms of release schedule.

genodeftest gravatar imagegenodeftest ( 2018-07-09 02:36:17 -0600 )edit

Thanks for the comment. The gnome-session-xsession is indeed already installed and the /usr/share/xsessions/gnome-xorg.desktop is present and readable.

vikjes1969 gravatar imagevikjes1969 ( 2018-07-10 18:35:46 -0600 )edit