System won't boot after having used an external HDD

asked 2018-07-09 16:11:54 -0500

Phil from Cumbria gravatar image

I recently had a friend give me a drive (usb3 external) as he had accidentally reformatted it. I recovered the data for him, now my system won't boot. I formatted his drive after recovery with gnome-disks. Everything worked as expected but if I unplug his drive from my system and boot up without it, it fails and hangs after the login screen., I have booted with it plugged in OK and unmounted it, unplugged it and it fails to boot. Is grub looking for the drive and did it get somehow added to my system because I formatted it with gnome disks. Strange thing is my system boots normally with an older kernel. Help would be much appreciated.

edit retag flag offensive close merge delete

Comments

Check content of /etc/fstab. If it's there,uncomment the line (put # at the beginning).

enenou gravatar imageenenou ( 2018-07-10 02:35:53 -0500 )edit

If it hangs after the login screen, it is way past grub and the initramfs. Can you switch to a tty and have a look at the syslog using journalctl -b?

genodeftest gravatar imagegenodeftest ( 2018-07-10 03:33:28 -0500 )edit

Thanks for your replies. I will have a go after work. I did look in /etc/fstab and the external drive was there. I got rid of the entry but the problem persisted and it returns after reboot. Maybe leaving it there and adding the uncomment symbol will do the trick. Regards phil

Phil from Cumbria gravatar imagePhil from Cumbria ( 2018-07-10 05:30:14 -0500 )edit