Ask Your Question
2

install mediatek

asked 2018-07-13 10:07:37 -0500

navid71 gravatar image

updated 2018-07-13 10:09:35 -0500

hhlp gravatar image

HI. I install fedora cinnamon and try to instsall my mediatek wifi driver with this source files from https://github.com/neurobin/MT7630E. my kernel version is 4.17.4. i think this driver not match on this kernel

$ ./install 
make -C /lib/modules/4.17.4-200.fc28.x86_64/build M=/home/navid/MT7630E/rt2x00 modules
make[1]: Entering directory '/usr/src/kernels/4.17.4-200.fc28.x86_64'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/usr/src/kernels/4.17.4-200.fc28.x86_64'
make: *** [Makefile:9: all] Error 2
----------------------------------------------------------------------

after this,

" $cd rt2x00 " to run  "build.sh":

$ ./build.sh 
rm: cannot remove './*.ko': No such file or directory
rm: cannot remove './*.o': No such file or directory
make: Entering directory '/usr/src/kernels/4.17.4-200.fc28.x86_64'
make: *** No targets specified and no makefile found.  Stop.
make: Leaving directory '/usr/src/kernels/4.17.4-200.fc28.x86_64'
---------------------------------------------------------------------

what should i do now?? ;-(

edit retag flag offensive close merge delete

Comments

@navid71 I think you have missing dependencies, try to install kernel-devel and kernel-headers and execute the process again...

hhlp gravatar imagehhlp ( 2018-07-13 10:12:39 -0500 )edit

I am almost up-todater-man in Iran. both of them resolved!

navid71 gravatar imagenavid71 ( 2018-07-13 11:39:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-13 11:33:35 -0500

navid71 gravatar image
[navid@ZyXEL4 rt2x00]$ sudo dnf install kernel-devel
[sudo] password for navid: 
Last metadata expiration check: 1:33:32 ago on Fri 13 Jul 2018 07:27:57 PM +0430.
Package kernel-devel-4.17.4-200.fc28.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

[navid@ZyXEL4 rt2x00]$ sudo dnf install kernel-headers
Last metadata expiration check: 1:33:45 ago on Fri 13 Jul 2018 07:27:57 PM +0430.
Package kernel-headers-4.16.3-301.fc28.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
edit flag offensive delete link more

Comments

1

A better solution is to install the driver using DKMS.

install git dkms build-essential

git clone https://github.com/neurobin/MT7630E.git

cd MT7630E/

sudo make dkms

(you can add KERNEL tag after dkms)

Note : Please contact your device manufacturer website for product driver downloads

nisankh gravatar imagenisankh ( 2018-07-13 12:46:47 -0500 )edit

the output is:

  [navid@ZyXEL1 rt2x00]$ sudo make dkms
    make: *** No rule to make target 'dkms'.  Stop.
navid71 gravatar imagenavid71 ( 2018-07-14 06:05:33 -0500 )edit
0

answered 2018-07-13 11:35:39 -0500

navid71 gravatar image

updated 2018-07-13 11:45:37 -0500

I think some kernel_headers of *.c and *.h files not available in my kernel!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-13 10:07:37 -0500

Seen: 103 times

Last updated: Jul 13