Ask Your Question
0

Activate swap partition on startup

asked 2018-08-09 14:32:04 -0600

revolucion09 gravatar image

Hi,

I have setup a Fedora 28 LVM partition, but for some reason SWAP does not activate on startup.

I have to manually go to KDE Partition Manager, right click on the swap partition and click "Activate"

How to this automatically? I don't see anything on the GUI

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
5

answered 2018-08-09 15:49:25 -0600

muep gravatar image

Usually the swap partition needs to be specified in /etc/fstab in order to be used.

For example, on my system there is a line like this:

/dev/mapper/korg-swap   swap                    swap    defaults        0 0

The first column is machine specific. To see what you should use instead of /dev/mapper/korg-swap, run sudo blkid to find the name of your swap partition.

I am not sure if there is a GUI for this, but you can at least just edit /etc/fstab to add a suitable line. To test if the line is OK, first have the swap not activated (like it is on boot) and then run sudo swapon -a. This should automatically activate swap partitions that are in /etc/fstab.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-08-09 14:32:04 -0600

Seen: 97 times

Last updated: Aug 09