Ask Your Question
1

yum fails with error Traceback (most recent call last): 126 File "/usr/bin/yum", line 29, in ? 127 yummain.user_main(sys.argv[1:], exit_code=True) Please help!

asked 2018-08-13 09:32:56 -0600

howardl gravatar image

updated 2018-08-13 11:10:04 -0600

hhlp gravatar image

d]

[15:27:44]# yum update
Loaded plugins: security
Webmin                                                                                    | 1.0 kB     00:00     
Webmin/primary                                                                            |  16 kB     00:00     
Webmin                                                                                                   119/119
epel                                                                                      | 3.4 kB     00:00     
epel/primary_db                                                                           | 1.3 MB     00:00     
rhel-5-server-rpms                                                                        | 3.4 kB     00:00     
rhel-5-server-rpms/primary_db                                                             |  13 MB     00:00     
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package autofs.x86_64 1:5.0.1-0.rc2.186.el5_11 set to be updated
---> Package bind-libs.x86_64 30:9.3.6-25.P1.el5_11.12 set to be updated
---> Package bind-utils.x86_64 30:9.3.6-25.P1.el5_11.12 set to be updated
---> Package device-mapper-multipath.x86_64 0:0.4.7-64.el5_11 set to be updated
---> Package firefox.i386 0:45.8.0-2.el5_11 set to be updated
--> Processing Dependency: libatomic for package: firefox
--> Processing Dependency: libatomic.so.1 for package: firefox
---> Package firefox.x86_64 0:45.8.0-2.el5_11 set to be updated
---> Package httpd.x86_64 0:2.2.3-92.el5_11 set to be updated
---> Package kernel.x86_64 0:2.6.18-419.el5 set to be installed
---> Package kernel-devel.x86_64 0:2.6.18-419.el5 set to be installed
---> Package kernel-headers.x86_64 0:2.6.18-419.el5 set to be updated
---> Package kpartx.x86_64 0:0.4.7-64.el5_11 set to be updated
---> Package libsmbclient.i386 0:3.0.33-3.41.el5_11 set to be updated
---> Package libsmbclient.x86_64 0:3.0.33-3.41.el5_11 set to be updated
---> Package lsscsi.x86_64 0:0.23-1.el4 set to be updated
---> Package nspr.i386 0:4.11.0-1.el5_11 set to be updated
---> Package nspr.x86_64 0:4.11.0-1.el5_11 set to be updated
---> Package nspr-devel.x86_64 0:4.11.0-1.el5_11 set to be updated
---> Package nss.i386 0:3.21.3-2.el5_11 set to be updated
---> Package nss.x86_64 0:3.21.3-2.el5_11 set to be updated
---> Package nss-devel.x86_64 0:3.21.3-2.el5_11 set to be updated
---> Package nss-tools.x86_64 0:3.21.3-2.el5_11 set to be updated
---> Package redhat-release.x86_64 0:5Server-5.11.0.9 set to be updated
---> Package samba.x86_64 0:3.0.33-3.41.el5_11 set to be updated
---> Package samba-client.x86_64 0:3.0.33-3.41.el5_11 set to be updated
---> Package samba-common.x86_64 0:3.0.33-3.41.el5_11 set to be updated
---> Package sos.noarch 0:1.7-9.74.el5_11 set to be updated
---> Package tzdata.x86_64 0:2017b-1.el5 set to be updated
---> Package webmin.noarch 0:1.890-1 set to be updated
--> Running transaction check
---> Package libatomic.i386 0:4.8.0-5.1.1.el5 set to be updated
---> Package libatomic.x86_64 0:4.8.0-5.1.1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================
 Package                        Arch          Version                            Repository                 Size ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-08-13 10:25:12 -0600

howardl gravatar image

I think I fixed it. I moved all repos from /etc/yum.repos.d and reinstated 1 by 1 until it stopped working then I knew which one was the problem.

edit flag offensive delete link more

Comments

does rhel use dnf now instead of yum? I do know fedora got rid of yum around f20 I think.

steveebey73742 gravatar imagesteveebey73742 ( 2018-08-13 12:44:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-13 09:32:56 -0600

Seen: 43 times

Last updated: Aug 13