Ask Your Question
0

WebGL doesn't work on Fedora Firefox

asked 2018-08-15 13:38:10 -0600

tanwald gravatar image

updated 2018-08-15 13:47:06 -0600

I keep having troubles with WebGL on Fedora Firefox. A few month ago Mesa was blacklisted and now something else seems to go wrong.

  • https://get.webgl.org says: "Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card."
  • mapbox-gl says: "Failed to initialize WebGL", so I cannot display any maps...
  • In Chromium and Brave on Fedora or Firefox on Mac everything works as expected.

Some info from about:support:

  • WebGL 1 Driver Renderer Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)
  • WebGL 1 Driver Version 3.0 Mesa 18.0.5
  • WebGL 2 Driver Renderer Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)
  • WebGL 2 Driver Version 4.5 (Core Profile) Mesa 18.0.5
  • HW_COMPOSITING blocked by default: Acceleration blocked by platform
  • OPENGL_COMPOSITING unavailable by default: Hardware compositing is disabled
  • WEBRENDER opt-in by default: WebRender is an opt-in feature unavailable by runtime: Build doesn't include WebRender
  • OMTP disabled by default: Disabled by default

System:

  • Kernel: 4.17.12-200.fc28.x86_64
  • Firefox: 61.0.2

Last time I could work around by setting webgl.force-enabled to true in about:config.

edit retag flag offensive close merge delete

Comments

I, too, am having this problem. Epiphany, Chromium all work fine. I remember Firefox working correctly before in itch.io so I don't know what the cause is. Have you found any other reports?

Alxe gravatar imageAlxe ( 2018-08-21 05:59:55 -0600 )edit

I too have this issue. WebGL support used to work for a long time in Fedora+Firefox, then it got broken in a specific version of Firefox 60 (see https://bugzilla.redhat.com/show_bug....), then that was fixed and WebGL worked for a while, and now it is broken again in the most recent version of Firefox 61.

wouterbeek gravatar imagewouterbeek ( 2018-08-29 12:13:28 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-08-31 13:40:36 -0600

tanwald gravatar image

I just found out that it seems to be a Firefox bug (https://bugzilla.mozilla.org/show_bug...) which will be resolved in version 62. I'd say that there are some coordination issues between Firefox/Mesa/Fedora/Linux/WebGL/Whatever. Anyway, it's annoying...

Tested with Firefox 62 beta and WebGL works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-15 13:38:10 -0600

Seen: 424 times

Last updated: Aug 31 '18