Ask Your Question
0

How do I install required glibc (32bit)?

asked 2018-08-17 07:10:00 -0600

I have a Brother MFC-J470DW all-in-one. I also run Fedora, openSUSE Tumbleweed, and Ubuntu. All distros are 64-bit. I have installed the drivers for the printer on all three distros. On Ubuntu 18.04, the printer and scanner work. On Fedora 28 and the latest Tumbleweed, I cannot print. I just get notifications that a print job started and a few seconds later, another notification that printing has completed.

After some online searching, I was led to /var/logs/cups/error_log. There is an entry there on both Fedora and openSUSE that says:

"[CGI] cups-brf must be called as root"

After more online searching, I found a post for that error in the openSUSE forums. It led me to do the following:

objdump -p /opt/brother/Printers/mfcj470dw/cupswrapper/brcupsconfpt1

which indicated (on Tumbleweed) that glibc-32bit was required. I installed that package and printing now works.

So I tried that on Fedora 28. The output from objdump is:

/opt/brother/Printers/mfcj470dw/cupswrapper/brcupsconfpt1: file format elf32-i386

Program Header: PHDR off 0x00000034 vaddr 0x08048034 paddr 0x08048034 align 22 filesz 0x000000c0 memsz 0x000000c0 flags r-x INTERP off 0x000000f4 vaddr 0x080480f4 paddr 0x080480f4 align 20 filesz 0x00000013 memsz 0x00000013 flags r-- LOAD off 0x00000000 vaddr 0x08048000 paddr 0x08048000 align 212 filesz 0x0000227c memsz 0x0000227c flags r-x LOAD off 0x00003000 vaddr 0x0804b000 paddr 0x0804b000 align 212 filesz 0x000008c0 memsz 0x00002ff0 flags rw- DYNAMIC off 0x000037a0 vaddr 0x0804b7a0 paddr 0x0804b7a0 align 22 filesz 0x000000c8 memsz 0x000000c8 flags rw- NOTE off 0x00000108 vaddr 0x08048108 paddr 0x08048108 align 22 filesz 0x00000020 memsz 0x00000020 flags r--

Dynamic Section: NEEDED libc.so.6 INIT 0x0804845c FINI 0x08049148 HASH 0x08048128 STRTAB 0x080482dc SYMTAB 0x080481bc STRSZ 0x000000ab SYMENT 0x00000010 DEBUG 0x00000000 PLTGOT 0x0804b87c PLTRELSZ 0x00000068 PLTREL 0x00000011 JMPREL 0x080483f4 REL 0x080483dc RELSZ 0x00000018 RELENT 0x00000008 VERNEED 0x080483ac VERNEEDNUM 0x00000001 VERSYM 0x08048388

Version References: required from libc.so.6: 0x0d696911 0x00 03 GLIBC2.1 0x0d696910 0x00 02 GLIBC2.0

So libc.so.6 is needed. Again, that would be the 32-bit version.

I tried to install it:

dnf install glibc.i686

This gives:

Package glibc-2.27-30.fc28.i686 is already installed, skipping.

Is this the wrong package? If so, what is the right package? Do I need to install a different version of glibc? If so, how?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-17 08:46:52 -0600

villykruse gravatar image

You have the correct glibc package installed, so that is not the problem

cups-brf is the backend for braille printing, so this is probably unrelated.

There used to be SELinux issues with Brother printers. Thus was fixed a while ago, but running in permissive mode would be worth trying.

edit flag offensive delete link more

Comments

Setting SELinux to permissive mode does allow me to print.

setenforce 1
setsebool -P cups_execmem=1

changes SELinux back to enabled and makes the change necessary to allow printing permanently.

Before I made these changes, I looked at [Troubleshooting SELinux] (https://fedoramagazine.org/troublesho...) and tried following it. I am not sure if doing anything in there causes a problem, but now when reboot, I get a flood of notifications about SELinux violations. I am not sure what to change to get rid of them.

Jim O gravatar imageJim O ( 2018-08-17 12:34:23 -0600 )edit

Are you up-to-date?

selinux-policy-3.14.1-40.fc28.noarch
selinux-policy-targeted-3.14.1-40.fc28.noarch
villykruse gravatar imagevillykruse ( 2018-08-17 13:17:59 -0600 )edit

Basically, sealert will tell you what to do. However, I would think that the flood of notifications has always been there.

villykruse gravatar imagevillykruse ( 2018-08-17 13:20:51 -0600 )edit

I realise that selinux will generate notifications for logging purposes. I just never saw them before in the notifications that are displayed in the Gnome desktop (below the time at the top of the screen.

Jim O gravatar imageJim O ( 2018-08-17 13:35:28 -0600 )edit

When I removed setroubleshoot, the visible notifications stopped.

Jim O gravatar imageJim O ( 2018-08-17 13:59:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-17 07:10:00 -0600

Seen: 83 times

Last updated: Aug 17