Ask Your Question
1

Gnome shell lag with totem in full screen on 4k display

asked 2018-08-18 08:11:41 -0500

hhyyrylainen gravatar image

I got a 3840x2160 display in my setup, I have 3 monitors in total. Watching a video in full screen using totem on the non-4k ones works perfectly with no lag or stuttering, but when I move the video over to my 4k screen and full screen it (everything works smoothly until I full screen it) the gnome shell starts lagging, dragging windows around, swapping workspaces etc. are laggy, but the contents of the windows don't lag themselves so it is only the window manager lagging.

Using vlc or chrome to watch a full screen video on the 4k display doesn't have this issue. And the lag with totem even happens if I play a video that doesn't actually have a moving image (just a still image). The lag goes away immediately if I un-full screen totem or pause the video. One last weird thing is that sometimes totem works smoothly in full screen but I haven't managed to find a pattern as that seems to happen quite randomly when reopening totem.

I'm using fedora 28, my gnome version is 3.28.3 and my totem version is 3.26.2. Both are the latest ones according to "dnf update".

I tried find if anyone had the same issue but I only found people who had every video lagging or totem always lagging in full screen (for me 2 out of my 3 monitors don't cause lag when I full screen totem on them). Any insight would be greatly appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-08-20 08:53:57 -0500

genodeftest gravatar image

updated 2018-08-20 08:54:41 -0500

TL;DR: Totem is missing video acceleration by default.

VLC uses libva (VA-API) or vdpau for video acceleration. Maybe Chrome does the same. Totem is based on GStreamer which has no video acceleration by default and only broken integration through gstreamer-vaapi.

Without hardware acceleration, rendering videos is consuming much CPU time and memory bandwidth. As a result, the CPU is working heavily for rendering the video in Totem and thus has no resources left for extra stuff like moving windows. 4k monitors are even worse because videos need to be upscaled, which consumes more CPU and bandwidth.

You may try installing gstreamer1-vaapi together with the libva driver for your platform, such as the libva-intel-driver (available through RPMFusion), libva-intel-hybrid-driver, libva-vdpau-driver (maybe including additional drivers for your GPU). Last time I checked these were utterly broken, so expect anything to break.

edit flag offensive delete link more

Comments

I don't think this is the issue as system monitor shows the CPU usage of totem to be only 1-3%. And when I don't play the video in full screen (I just have the window maximised so that it covers the entire screen, there's just the title bar taking some space) I don't get any lag. So I don't think the decoding performance is the issue. But I tried your suggestion. I already had "gstreamer1-vaapi" installed and I have a nvidia card and "libva-vdpau-driver" installed but I did try installing "libva-intel-driver" as well but nothing changed.

hhyyrylainen gravatar imagehhyyrylainen ( 2018-08-20 10:55:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-18 08:11:41 -0500

Seen: 161 times

Last updated: Aug 20 '18