Ask Your Question
0

I am having trouble dual booting Win10 and Linux to my Lenovo 330S

asked 2018-08-29 13:26:55 -0500

Grog gravatar image

I partitioned my C: drive, downloaded a fedora 28 live boot to a thumb drive, and tried to boot it. When it starts, I get a stack dump as follows:

[Firmware Bug]: AMD-Vi IOAPIC[32] not in IVRS table
Kernel Panic - not syncing: timer doesn't work through Interrupt-remapped IO-APIC
CPU:0 PID: 0 Comm: swapper/0 Not tainted 4.16.3-301.fc.28.x86_64 #1
Hardware name: LENOVO 81FB/LNVNB161216, BIOS 7WCN21WW 05/11/2018
Call Trace:

dump_stack+0x5c/0x85
  panic+0xe7/0x247
  panic_if_irq_remap.cold.0+0x5/0xe
  setup_IO_APIC+0x35a/0x7c4
  ? clear_io_APIC_pin+0xb8/0x110
  x86-late-time_init+0x17/0x1c
  start_kernel
  secondary_startup_64

For what it is worth, I got a very similar result with a Ubuntu 29 live boot.

Can anybody point me in the right direction?

edit retag flag offensive close merge delete

Comments

Check if you have UEFI secure boot activated, it may be blocking some kernel module require on your pc. You could disable it and try to boot as a test.

aeperezt gravatar imageaeperezt ( 2018-08-29 13:51:35 -0500 )edit

In response to aeperezt's suggestion about UEFI secure boot, I have tried this with the BIOS set for UEFI, and for legacy boot.

Grog gravatar imageGrog ( 2018-08-29 14:53:35 -0500 )edit

I you did have the same error, then try to install with compatibility mode.

aeperezt gravatar imageaeperezt ( 2018-08-29 15:01:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-29 15:41:05 -0500

cmurf gravatar image

When I Google this error message, the vast majority response is to use the noapic boot parameter. So you need to edit the GRUB entry (type e at the grub menu) and then find the linuxefi line, and then somewhere in that line after vmlinuz insert noapic and then either control-x or F10 to boot. If that works, you'll need to make the change permanent by editing the proper boot parameter line in /etc/default/grub and then creating a new grub configuration using sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

I do not recommend disabling Secure Boot or using compatibility/legacy/disable UEFI mode. That is not indicated.

edit flag offensive delete link more

Comments

This did the trick.I clicked the "check" above. Is there anything else I need to do to say thanks?

Grog gravatar imageGrog ( 2018-08-30 12:46:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-29 13:26:55 -0500

Seen: 757 times

Last updated: Aug 29 '18