Ask Your Question
3

clementine can't play .wma files

asked 2018-09-15 22:23:08 -0500

fasulia gravatar image

updated 2018-09-18 14:06:43 -0500

Fedora 28

Clementine 1.3.1.27.fc28

Clementine shows "Buffering 0%..." when attempting to play .wma files.

It sometimes plays a .wma file after the previous track ends and it moves automatically to a .wma file. Even then, skipping within the audio track or to another .wma file results in the same buffering message and not playing.

EDIT: In Linux Lite 4.0 (based on Ubuntu 18.04) and clementine version 1.3.1+git276-g3485bbe43+dfsg-1.1build1, .wma files play after package ubuntu-restricted-extras is installed.

EDIT2:Installed/available gstreamer-related packages/plugins on Fedora 28: https://paste.fedoraproject.org/paste...

edit retag flag offensive close merge delete

Comments

If it wasn't playing .wma files at all, I would say you are missing a gstreamer codec (plugin). Since it sometimes work, it may be a bug in Clementine. Can you try to use VLC and play the .wma files that are not playing with Clementine? Just making sure the files themselves are Ok.

Also, I would suggest you start clementine from Command line and see what the outputs are when you attempt to play a .wma file.

florian gravatar imageflorian ( 2018-09-17 10:03:39 -0500 )edit

Yes, I checked with a few different .wma files and they do play with VLC and mplayer.

fasulia gravatar imagefasulia ( 2018-09-17 13:14:18 -0500 )edit

Can you play the file in another GStreamer1-backed media player like totem (default GNOME video player)? If yes, this looks like a bug in clementine.

genodeftest gravatar imagegenodeftest ( 2018-09-18 05:23:55 -0500 )edit

Totem works. There are some CRITICAL (eg. "gsignalhandlersdisconnectmatched: assertion 'GTYPECHECK_INSTANCE (instance)' failed") and WARNING (eg. "invalid (NULL) pointer instance") messages printed in the terminal, but it plays without problem.

fasulia gravatar imagefasulia ( 2018-09-18 10:57:17 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-09-18 03:44:21 -0500

hhlp gravatar image

updated 2018-09-18 08:05:56 -0500

@fasulia , some workaround come to my mind execute clementine in terminal and paste the error here another question is Are you sure you instaled all video and codec necesary -> what-plugins-do-i-need-to-install-to-watch-movies-and-listen-to-music that why in ubuntu with these ubuntu-restricted-extras works

Updated

I install it clementine and say some gstreamer plugins unavailable to reproduce this kind of codec...

Reason

Thinking about your problem some light come to my mind and I find a post You can read, in this post that I wrote some times ago, describe the problem, the reason (portability problem) and howto proceed :

how-to-play-mp3-files-with-rhythmbox

however I write here again with a bold in your media player :

I would like to clarify why we need all this stuff and why we have to install both gstreamer and gstreamer1, and how this change begin:

  1. GNOME Goal: Port your application to GStreamer 1.0
  2. to install plug-ins in FEDORA 17 -> #625.
  3. in FEDORA 18 the things change a little, GNOME 3.6 uses gstreamer1 instead of gstreamer, some plugins use the same name other changed and other simple disappeared.
  4. to install plug-ins in FEDORA 18 -> #3359.
  5. seemingly in rythmbox has a bug that force to use the old plug-ins instead of the new one
  6. that why some program like TOTEM and GNOME-MPLAYER and MPLAYER use this features and other like CLEMENTINE no -> #3769.

NOTE : in conclusion check is your application was ported or not and install the respective gstreamer or check if you have to need both.

hth

edit flag offensive delete link more

Comments

How can I check if clementine was ported or not? In any case I installed all of the gstreamer0.1/1 plugins in your links and more, and it still does not play .wma normally. Yes, you will encounter a "gstreamer missing plugin" before installing plugins, but then afterwards, there is the "buffering 0%..." problem.

fasulia gravatar imagefasulia ( 2018-09-18 11:22:26 -0500 )edit

you have to check package dependency , Try installing the gstreamer1-libav package from rpmfusion

hhlp gravatar imagehhlp ( 2018-09-18 13:16:25 -0500 )edit

I have that and a couple dozen gstreamer-related packages installed. Please see the fpaste link I added to the question showing installed and available packages. Are there any others that I should install?

fasulia gravatar imagefasulia ( 2018-09-18 14:04:36 -0500 )edit
1

$ dnf repoquery --requires clementine clearly tells that Clementine is using GStreamer 1. No need to install any packages.

genodeftest gravatar imagegenodeftest ( 2018-09-19 02:29:00 -0500 )edit
0

answered 2018-09-17 10:05:01 -0500

florian gravatar image

A quick search shows that someone has already filed this behavior with the developers: https://github.com/clementine-player/...

edit flag offensive delete link more

Comments

I opened the issue. There are no replies, and given how many open issues there are it doesn't seem very likely. I'm not sure if the problem is with Clementine or with dependency versions installed in Fedora. Would be nice to know if other distros have the same issue.

fasulia gravatar imagefasulia ( 2018-09-17 13:33:55 -0500 )edit

Boot a Debian, Ubuntu or whatever live system and try it out.

florian gravatar imageflorian ( 2018-09-17 14:10:09 -0500 )edit

Updated question: it works in Linux Lite 4.0 (Ubuntu 18.04), after installing ubuntu-restricted-extras. Is the problem with Fedora or dependencies?

fasulia gravatar imagefasulia ( 2018-09-17 20:22:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-15 22:23:08 -0500

Seen: 95 times

Last updated: Sep 18