Ask Your Question
1

fedora 28:laptop fails to mount USB disks

asked 2018-09-23 00:34:28 -0600

updated 2018-09-23 01:54:17 -0600

I occasionally had this issue with f:27 before upgrading to f:28 but, now no matter what I do my USB drives are not mounted when I connect them USB sticks and USB Hard Drives.

I used to work around by plugging into a different USB port but that no longer works.

Sometimes but not always I get the USB drive connected sound on plugging in whereas I used to get that always regardless if the drive was mounted.

a) How can I restore automatic mounting? b) As a workaround, how can I mount the drives manually?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-09-23 02:23:24 -0600

abadrinath gravatar image

If you are on GNOME, you should be able to open up the GUI for viewing the disk partitions, under which a list of storage devices will be listed. Find your USB and edit the options to allow for automatic mounting.

To manually mount a partition, find the symbolic mountpoint in /dev as listed by lsblk (try and scope out which one it is using the size -- USBs should be small from 8GB to 256GB). You can try and find the name of the partition in the above GUI as well. Once found, just create a place to mount it temporary with mkdir or a file manager, then:

mount /dev/the-mountpoint /mnt/somewhere

To summarize, this could be a potential command that creates mount directory and mounts:

mkdir /mnt/rmable && mount /dev/sdb1 /mnt/rmable

Hope that helps.

edit flag offensive delete link more

Comments

Thank you. When you say GUI (I am on GNOME), what GUI? Mount seems to work on the command line but nothing shows up in Nautilus still - it used to show the disk with an eject button below Other Locations automatically.

Willtech gravatar imageWilltech ( 2018-09-23 04:23:01 -0600 )edit

NVM - found the cause. Old entry in fstab for a second swap not present on sdb1 and first USB disks being assigned sdb. Cleaned that up and now all drives plugging correctly.

Willtech gravatar imageWilltech ( 2018-09-23 04:47:22 -0600 )edit
1

answered 2018-09-23 12:06:48 -0600

cmurf gravatar image

Follow the journal live while inserting a USB stick to see what's going on:

sudo journalctl -f

First, the kernel must display messages indicating it sees the insertion of the USB device, and is instantiated in /dev/, and its partition map is discovered. Only then will user space tools like udev and udisks2 be able to do something with it, including automounting. There are some rules as to what kinds of partition types and file systems won't automount, but for common types: NTFS, FAT, HFS+, and most Linux file systems, it should be automounted.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-23 00:34:28 -0600

Seen: 91 times

Last updated: Sep 23