Ask Your Question
2

Gnome software stuck in endless startup loop

asked 2018-09-24 10:22:38 -0500

thyregod gravatar image

updated 2018-09-24 11:32:45 -0500

I've run into a problem where my Desktop is unable to start Gnome Software. Every time I try to boot it, it's stuck at "Software catalogue is being loaded" (see screenshot)

I've tried running it in sudo, re-installing it, giving it several hours to think in, but nothing has helped me. I haven't been able to see an error of relevance when running in sudo as far as my skills allowed.

EDIT: Running 'sudo gnome-software' returns this terminal output while stuck at same place

edit retag flag offensive close merge delete

Comments

Try running the software catalog manually by executing pkcon refresh force from a command line. See if that fixes the problem.

florian gravatar imageflorian ( 2018-09-24 11:25:48 -0500 )edit

The output from that command gives this error:

Fatal error: Error when getting information for file “/var/cache/PackageKit/28/metadata/rpmfusion-nonfree-steam/repodata/appstream.xml.gz”: No such file or directory

Could it be related to the problem?

thyregod gravatar imagethyregod ( 2018-09-24 11:30:39 -0500 )edit
1

Yes, for sure. PackageKit is very buggy. Probably it doesn't know how to deal with this kind of error and remains stuck.

Don't run gnome-software using sudo. That's not needed, is not supposed to work (on Wayland), and not part of your problem.

pkcon repo-disable rpmfusion-nonfree-steam should disable the faulty repo.

Gnome Software causes all sorts of problems, do you think you could dnf instead? Start with this: sudo dnf update.

florian gravatar imageflorian ( 2018-09-24 12:46:11 -0500 )edit

Output of the disable command:

Modifying repository          [=========================]         
Finished                      [=========================]         
Fatal error: repo already disabled

dnf returns nothing to do. I've recently tried to run that command in case that would help.

thyregod gravatar imagethyregod ( 2018-09-24 12:57:50 -0500 )edit

dnf doesn't fix your problem with gnome-software / PackageKit. But you could use it instead and have less headache.

repo already disabled sounds good. What if you re-run pkcon refresh again?

You can also delete everything in: /var/cache/PackageKit/28 and retry!

florian gravatar imageflorian ( 2018-09-24 13:26:54 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-23 15:24:15 -0500

On Fedora 29, this worked for me:

sudo rm -r /var/cache/PackageKit/29/*

I was then able to refresh the cache with

pkcon refresh force

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-09-24 10:22:38 -0500

Seen: 482 times

Last updated: Sep 24 '18