Ask Your Question
3

Cannot connect Android device Fedora KDE

asked 2018-09-29 09:54:20 -0600

greenz1 gravatar image

While trying to connect Moto G4 or OnePlus 6 I get a cryptic error. The issue is that in the case of Moto G4 Android studio identifies that Moto G4 is connected whereas in case of OnePlus 6 it shows a '<alphanumeric-identifier> [null]'. However, the error shown by KIO client in both cases is identical.

Most of the solutions I have found suggest installing kio_mtp package which I already have in my system. I have also reinstalled this package. And I have tried changing udev rules which also comes up very often as a solution. Here are the udev rules.

SUBSYSTEM=="usb", ATTR{idVendor}=="0x04e8", MODE="0x0666"
SUBSYSTEM=="usb",ATTR{idVendor}=="0x04e8",ATTR{idProduct}=="0x6860",SYMLINK+="android_adb"
SUBSYSTEM=="usb",ATTR{idVendor}=="0x04e8",ATTR{idProduct}=="0x6860",SYMLINK+="android_fastboot"

Moto G4 KIO Client Error while selecting 'Open with File Manager' option from device notifier. image description

This is what Android Studio shows image description

In this case, Android Studio can install the app and read the logs.

OnePlus 6 KIO Client Error while selecting 'Open with File Manager' option from device notifier. image description

This is what Android Studio shows image description

In this case, Android Studio can install the app but cannot read the logs.

Can you point me in the right direction so that we can fix this issue?

edit retag flag offensive close merge delete

Comments

Yes, the developer mode is on. Otherwise, I wouldn't be seeing the device in Select Deployment Target window. Also, sudo udevadm monitor shows that the device keeps reconnecting. And adb logcat prints the logs for Moto G4 but not for OnePlus 6

Yes, the question in the link mentioned by you was added by me.

Can you please elaborate >check the deployment packages for supported API in android studio

greenz1 gravatar imagegreenz1 ( 2018-09-30 01:45:53 -0600 )edit

I was away for two days. Sorry for late reply. All the packages except gvfs-mtp were installed. So, I installed it but it didn't help.

I have installed API24 and API28 in Android Studio for that purpose.

greenz1 gravatar imagegreenz1 ( 2018-10-02 03:22:58 -0600 )edit

simple-mtpfs -l shows that the Moto G4 is connected but I cannot find it in Dolphin or Konqueror.

greenz1 gravatar imagegreenz1 ( 2018-10-02 03:24:03 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-11-07 23:23:03 -0600

greenz1 gravatar image

I was able to connect my phone with Android Studio but not with Konqueror. A 2013 thread discussed a similar problem. OnePlus needs to be connected using PTP instead of MTP. So, in the android device click on the system notification. And change the USB connection to PTP or Transfer Photos. Android Studio will recognize the device but the KDE client still doesn't.

PS: I switched to GNOME flavored Fedora for now. But I miss KDE

edit flag offensive delete link more

Comments

MTP has recently been rewritten from scratch, but it's yet to land in Fedora with KDE Applications 18.12: Here's a blog post by KDE developer: https://pointieststick.wordpress.com/...

You could try it out now by live-boooting some fresh KDE Neon image.

Temporarily you could switch to Cinnamon, usability-wise it's much closer to Plasma and, apart from some very old android versions, I've had no issues with MTP.

ozeszty gravatar imageozeszty ( 2018-11-08 03:20:10 -0600 )edit

Thank you for the info. It looks interesting. I will look into KDE Neon images. I will stick with GNOME for a while at work.

greenz1 gravatar imagegreenz1 ( 2018-11-10 02:04:51 -0600 )edit
-1

answered 2018-09-29 10:12:52 -0600

heliosstyx gravatar image

You should use KDE-connect, it works fine with all my Sony devices. You must install this App (KDE-Connect) under Android on each device too. Don't forget to allow "KDE-connect" under settings of Fedora Firewall (Zone!). It should work very well and you can do many things with KDE-Connect (for more see the appropriate documentation).

edit flag offensive delete link more

Comments

My goal is to be able to work with Android Studio. Will KDE-connect help in facilitating that?

greenz1 gravatar imagegreenz1 ( 2018-09-29 11:59:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-29 09:54:20 -0600

Seen: 89 times

Last updated: Nov 07