Ask Your Question
0

libssl 1.0.0 in Fedora 28

asked 2018-10-20 14:22:34 -0600

WizardLink gravatar image

I could not find anywhere a way to install libssl 1.0.0 in my Fedora 28 (In a 64bit architecture). Does someone knows a way to possibly achieve that?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

@WizardLink What packages needs that lib?

hhlp gravatar imagehhlp ( 2018-10-21 05:26:50 -0600 )edit

It is not a package, a software needs it. More specifically a steam ds needs it and to run it specifically needs 1.0.0

WizardLink gravatar imageWizardLink ( 2018-10-21 12:24:35 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2018-10-21 04:30:30 -0600

villykruse gravatar image

The closest available for fc28 is compat-openssl10.

dnf install compat-openssl10

That would provide libssl.so.10 which may be a good enough match for libssl 1.0.0.

edit flag offensive delete link more

Comments

It needs to be specifically 1.0.0, thanks for the support though!

WizardLink gravatar imageWizardLink ( 2018-10-21 12:24:47 -0600 )edit

The following worked for me to get compat-openssl10 recognised as 1.0.0:

su
cd /usr/lib64
ln -s libssl.so.1.0.2o libssl.so.1.0.0
ln -s libcrypto.so.1.0.2o libcrypto.so.1.0.0
watercannon gravatar imagewatercannon ( 2018-10-30 20:22:00 -0600 )edit

Sorry for the late reply, that worked for me, thank you! o/

WizardLink gravatar imageWizardLink ( 2018-11-04 15:32:09 -0600 )edit
0

answered 2018-11-04 07:49:29 -0600

genodeftest gravatar image

OpenSSL 1.0.0 is not supported by upstream any more. Having steam depend on that software and version is a pretty massive security bug. Can you update steam? Does the new version have sane dependencies, i.e. on version 1.0.2 or later? If not, I highly recommend not using software from such irresponsible or incompetent authors.

edit flag offensive delete link more

Comments

See also https://www.openssl.org/policies/rele... for details on which openssl versions are supported and which are not.

genodeftest gravatar imagegenodeftest ( 2018-11-04 07:50:47 -0600 )edit

Nothing these developers can do. The engine is too old.

WizardLink gravatar imageWizardLink ( 2018-11-04 15:32:25 -0600 )edit
0

answered 2018-10-20 22:58:24 -0600

florian gravatar image

updated 2018-10-20 23:00:56 -0600

libssl is part of OpenSSL.

Run rpm -qa openssl or dnf info openssl to check your version installed/available. In the repositories of Fedora 28, it is currently

openssl-1.1.0i-1.fc28.src.rpm

In order to compile with the libssl api, you need openssl-devel

edit flag offensive delete link more

Comments

Yes, it is in that exact version but I need libssl 1.0.0 specifically for a software to properly work in a 64 bit architecture.

WizardLink gravatar imageWizardLink ( 2018-10-21 12:31:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-20 14:22:34 -0600

Seen: 769 times

Last updated: Nov 04 '18