Ask Your Question
1

Brave Browser update issue

asked 2018-10-23 15:47:46 -0500

kazumi gravatar image

$ sudo dnf upgrade

Gives me: Failed to synchronize cache for repo 'brave-browser', disabling.

How can I solve this?

edit retag flag offensive close merge delete

Comments

It depends on what you do with this repository. Do you still need it? If not, delete “/etc/yum.repos.d/brave-browser.repo” or better disable it (take a look at the file, setting is obvious) If you still need it, contact the repo owner for a fix.

florian gravatar imageflorian ( 2018-10-23 16:54:07 -0500 )edit

Thanks! I'm guessing that I would need the repo to keep the Brave browser up to date?

kazumi gravatar imagekazumi ( 2018-10-24 09:22:22 -0500 )edit

Generally speaking yes, If you still have the browser installed keep the repo enabled and tell the maintainer/owner of the repo that it is not available for syncing. Sometimes this can be a temporary problem - so try again a few hours/days later and see what happens. If the problem persists contact the repo owner!

florian gravatar imageflorian ( 2018-10-24 11:13:26 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-04-15 19:02:25 -0500

If anybody has used this work-around, I strongly recommend you undo it:

chattr -i /etc/cron.daily/brave-browser

If you don't do this before upgrading to 0.63, you won't get the fix that got added in https://github.com/brave/brave-core/p....

edit flag offensive delete link more
-1

answered 2019-02-04 12:23:37 -0500

Aeyoun gravatar image

updated 2019-02-04 12:24:08 -0500

At the stroke of midnight, Brave runs a script on Fedora that destroys its own repository. This makes it impossible to update brave without some manual repair. The following sets of commands works-around the issue:

# Disable the daily self-destruction script by replacing it with an empty file
echo "" > /etc/cron.daily/brave-browser
# Ensure the file isn’t restored by future updates to Brave
chattr +i /etc/cron.daily/brave-browser

To repair a broken repository file edit /etc/yum.repos.d/brave-browser.repo and set the baseurl option to https://brave-browser-rpm-release.s3.brave.com/x86_64/ replacing http://dl.google.com/….

The upstream issue is brave/brave-code#1553.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-10-23 15:47:46 -0500

Seen: 628 times

Last updated: Feb 04