Ask Your Question
0

How can I play MP4 files in Fedora Labs 28? [closed]

asked 2018-10-27 07:20:21 -0500

rajarshi gravatar image

updated 2018-10-27 07:23:22 -0500

I have used Linux for several years now, but I have only used GNOME so far. A few days back, I shifted to Fedora Labs 28, which uses KDE. Since then, I have had some problems.
I used Dragon Player to play WEBM files, and it worked like a charm. However, when I tried to use the same to play MP4 files, I discovered that the files could not be played in Dragon Player. I tried installing Totem, but Totem couldn't play the files either.
I attempted to install Gstreamer codecs, but I discovered that even that didn't change anything in any useful way. Is there a way to run MP4 files in KDE, or at least some software to convert them to WEBM so that I can run them?

BTW my version of Linux:
Linux localhost.localdomain 4.18.16-200.fc28.x86_64 #1 SMP Sat Oct 20 23:53:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by genodeftest
close date 2018-11-04 06:39:27.986985

Comments

Have you tried vlc player?

sulthan90 gravatar imagesulthan90 ( 2018-10-27 07:36:20 -0500 )edit

Ah, I had completely forgotten about VLC!! Thanks a ton, it worked! I downloaded VLC Media Player just now. And to think, I went into all that trouble, when VLC Media Player would have sufficed all along :D

rajarshi gravatar imagerajarshi ( 2018-10-27 08:49:30 -0500 )edit
1

You need the nonfree codecs by enabling rpmfusion-nonfree or negativo17. I guess VLC already pulled all dependencies by now. I prefer mpv to the bloated vlc. SMplayer is a KDE frontend for mpv if you like a GUI.

fcomida gravatar imagefcomida ( 2018-10-27 09:13:41 -0500 )edit

@rajarshi , have you tried this

dnf install xine-lib* k3b-extras-freeworld

from here

hhlp gravatar imagehhlp ( 2018-10-28 05:20:20 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-10-27 11:12:07 -0500

sulthan90 gravatar image

Installing the VLC player will solve this issue use the following commands

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
sudo dnf install vlc
dnf install python-vlc npapi-vlc (optionals)
edit flag offensive delete link more

Comments

@rajashri Mark the post as solved as the problem is resolved now after installing vlc

sulthan90 gravatar imagesulthan90 ( 2018-10-27 11:13:31 -0500 )edit
0

answered 2018-11-04 06:39:02 -0500

genodeftest gravatar image

This question is a duplicate of https://ask.fedoraproject.org/en/ques....

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-10-27 07:20:21 -0500

Seen: 485 times

Last updated: Nov 04 '18